Mp3 500, 2009 Horn on with ignition key
Post Reply    Forum -> MP3 Discussion
Author Message
Member
piaggio MP3 500
Joined: 04 May 2018
Posts: 14
Location: Buffalo NY
Fri Jan 04, 2019 3:15 pm quote
The bike has been stored in a damp garage for 4 months so something could be corroded-even some of the nuts and bolts are rusty. When the key is turned on the horn turns on and does not stop until the key is turned off. Any ideas-thanks Jim
Veni, Vidi, Posti
Neutrino MP3 492.7 AK, 2013 Moto Guzzi Norge
Joined: 29 Mar 2008
Posts: 21107
Location: Kingston, Tennessee, Tn
Fri Jan 04, 2019 3:55 pm quote
low hyd pressure in the tilt lock system.

make sure its on the center stand. start the scoot and cycle the tilt lock on/off 3-5 times and it should clear up.
Member
piaggio MP3 500
Joined: 04 May 2018
Posts: 14
Location: Buffalo NY
Sat Jan 05, 2019 6:39 am quote
Horn on
Thank you Old As Dirt-it worked. Jim
Enthusiast
Piaggio Medley 150 iGet and Drive Easy Rider Scooter
Joined: 04 Dec 2018
Posts: 52
Location: Brisbane, Australia
Sat Jan 05, 2019 1:15 pm quote
Re: Horn on
Roy2000 wrote:
Thank you Old As Dirt-it worked. Jim
My lasting solution: I prop the scoot on the centre stand, then push the toggle to the right, hear two beeps (tilt lock off) and never hear the horn again when turning the key to start.
Enthusiast
2009 MP3 400ie
Joined: 31 May 2016
Posts: 58
Location: philippines
Thu Feb 21, 2019 12:26 pm quote
just want to share my experience
Unfortunately yesterday I have experienced the same problem..I checked the fluid level for the tilt mechanism but its still full so I knew It could be the sensor that causing the alarm. I'm very worried because I cant just call up shops here in the Philippines to ask for parts especially for our MP3 because no Vespa shops here carries MP3s anymore and Im worried that I would have to order online and it will take sometime to get it.. So I called my mechanic and told him the problem.. i was suprised that he said "just bring it here and i'll fix it its just a quick fix" wow i was suprise to hear that.. when i got to his shop he removed the sensor with Blue connector then he just open up the sensor did a little surgery on it and WALA its fixed within 30mins. I didnt know that sensors can be repaired. Have you guys tried that too?
Ossessionato
2016 MP3/500 Sport ABS, 2009 MP3/250, 2012 GTS Super 300ie
Joined: 08 Jul 2011
Posts: 4154
Location: Marietta, GA
Fri Feb 22, 2019 10:18 am quote
Re: just want to share my experience
envirosolarmate wrote:
Unfortunately yesterday I have experienced the same problem..I checked the fluid level for the tilt mechanism but its still full so I knew It could be the sensor that causing the alarm. I'm very worried because I cant just call up shops here in the Philippines to ask for parts especially for our MP3 because no Vespa shops here carries MP3s anymore and Im worried that I would have to order online and it will take sometime to get it.. So I called my mechanic and told him the problem.. i was suprised that he said "just bring it here and i'll fix it its just a quick fix" wow i was suprise to hear that.. when i got to his shop he removed the sensor with Blue connector then he just open up the sensor did a little surgery on it and WALA its fixed within 30mins. I didnt know that sensors can be repaired. Have you guys tried that too?
I wonder if he did some sort of "By-Pass" ?
I think I would order one anyway from any source that you use.

Keith,
Marietta, GA
Enthusiast
2009 MP3 400ie
Joined: 31 May 2016
Posts: 58
Location: philippines
Sat Feb 23, 2019 1:46 pm quote
Re: just want to share my experience
klaborde wrote:
envirosolarmate wrote:
Unfortunately yesterday I have experienced the same problem..I checked the fluid level for the tilt mechanism but its still full so I knew It could be the sensor that causing the alarm. I'm very worried because I cant just call up shops here in the Philippines to ask for parts especially for our MP3 because no Vespa shops here carries MP3s anymore and Im worried that I would have to order online and it will take sometime to get it.. So I called my mechanic and told him the problem.. i was suprised that he said "just bring it here and i'll fix it its just a quick fix" wow i was suprise to hear that.. when i got to his shop he removed the sensor with Blue connector then he just open up the sensor did a little surgery on it and WALA its fixed within 30mins. I didnt know that sensors can be repaired. Have you guys tried that too?
I wonder if he did some sort of "By-Pass" ?
I think I would order one anyway from any source that you use.

Keith,
Marietta, GA
I thinks theres a thin hard plastic inside that has a tiny hole where it holds the fluid to keep the pressure when that tiny hole tears thats where we loose the pressure he just improvised to replicate the plastic seal and it works. he said he had been doing this to several mp3s no back jobs... hope this helps to some of you who likes DIY .
Member
Fuoco 500
Joined: 08 Nov 2010
Posts: 49
Location: Johannesburg South Africa
Mon Feb 25, 2019 3:32 am quote
Re: just want to share my experience
My Fuoco 500 had exactly the same problem after I returned from 4 week vacation. I have an aftermarket horn so the noise was quite something. Switched on and off and it eventually stopped and have not had the problem since.
Land of 10,000 Scoots Rally   Vespa Wasp Pin Badges   Yelcome Leather Top Cases and Roll Bags for Piaggio Vespa PX LX LXV GTS GTV
Post Reply    Forum -> MP3 Discussion
[ Time: 0.1808s ][ Queries: 23 (0.0339s) ][ Debug on ]