Engine light on, lots of backfiring
Post Reply    Forum -> MP3 Discussion
Author Message
Addicted
MP3 400 "Merlin"
Joined: 01 Jul 2012
Posts: 923
Location: Northwest Ohio
Sat Aug 22, 2020 10:48 am quote
We’re away from home on a weekend ride and my 400 is backfiring like popcorn when I slow down. Also the check engine light goes on and off. Otherwise it seems to be running fine. Ideas welcome!
Hooked
2009 MP3 400, 2004 Honda ST1300
Joined: 11 Jun 2007
Posts: 254
Location: Sayre, PA
Sat Aug 22, 2020 11:15 am quote
Oh dear.

Popping on overun is too rich fuel igniting in the exhaust. Common with carburetors but mostly eliminated with fuel injection.

Check engine light is strictly fuel injection monitoring. Intake air sensor? Temperature sensor? Throttle position sensor? O2 sensor? Something is feeding the system incorrect data and throwing the mixture off.

Loose connector? Damaged wiring? Malfunctioning sensor? Leaking fuel injector? Coolant level okay?
Moderaptor
The Hornet (GT200, aka Love Bug) and 'Dimples' - a GTS 300
Joined: 26 Aug 2007
Posts: 38982
Location: Pleasant Hill, CA
Sat Aug 22, 2020 12:40 pm quote
Check the exhaust gasket (graphite collar) - this can induce backfiring by mucking up the back-pressure. If the exhaust starts getting louder as well, that's your culprit. Install your spare.
Addicted
MP3 400 "Merlin"
Joined: 01 Jul 2012
Posts: 923
Location: Northwest Ohio
Sat Aug 22, 2020 4:40 pm quote
jimc wrote:
Check the exhaust gasket (graphite collar) - this can induce backfiring by mucking up the back-pressure. If the exhaust starts getting louder as well, that's your culprit. Install your spare.
Well, as you probably know, we’ve had issues keeping the muffler attached. After I get it home we’ll be going over it with a fine toothed come again. 😀
Addicted
MP3 400 "Merlin"
Joined: 01 Jul 2012
Posts: 923
Location: Northwest Ohio
Mon Aug 24, 2020 11:07 am quote
Update: Air filter did have engine oil in it. Right before the trip I'd check the oil and it was right on the lowest line so I added a small amount. Apparently that was too much. (Hubby duly slapped my wrist)

Air filter cleaned, oil level checked (on the stand, it's between the lines now), and while the air box was off we ran some throttle body cleaning spray through the air intake. Hubby is putting it back together now. Fingers crossed. The engine was running a little unevenly during the trip but it seems like a steady hum now. If the light comes back on, I'll have them check it in Cleveland when I take it to have the steering bearings replaced.

As always, thanks for your help. <3

Edit:
Graphite bushing on muffler looks fine. It's only a couple months old. Also, the spark plug was just changed last year. And the coolant level is normal.
Addicted
MP3 400 "Merlin"
Joined: 01 Jul 2012
Posts: 923
Location: Northwest Ohio
Tue Aug 25, 2020 6:12 pm quote
New update:

The bike is not backfiring *as much*, but it is still popping here and there. The engine light comes on when I'm under power but goes off at low RPMs and at every stop sign/light. There is a rattle at low RPMs that sounds like it's coming from the muffler.

Otherwise the engine sounds fine, no loss of power, no hesitation or stalling. At this point I'm going to just ask the mechanic at Cleveland Moto to go over it, tune it up, etc. when I take it in for the steering bearings. I anticipate a hefty bill but it'll be worth it to get it running smoothly again.
Land of 10,000 Scoots Rally   Vespa Wasp Pin Badges   Yelcome Leather Top Cases and Roll Bags for Piaggio Vespa PX LX LXV GTS GTV
Post Reply    Forum -> MP3 Discussion
[ Time: 0.1392s ][ Queries: 25 (0.0333s) ][ Debug on ]