Piaggio Mp3 - Thermometer problem (It says LO)
Post Reply    Forum -> MP3 Discussion
Author Message
Member
Piaggio Mp3 2009
Joined: 16 Jul 2016
Posts: 5
Location: Slovakia
Sat Jul 16, 2016 2:34 am quote
Hi all, I just bought Piaggio Mp3 400 2009 from second hand and I still have problem with thermometer.

On LCD it says LO instead temterature.

Could you help me with this?

Can you tell me, where is situated the Thermometer on scooter? It helps me.

I just add photo of it.


Thanks a lot for help guys.

7746299_7.jpg
LO on LCD display.

Veni, Vidi, Posti
Neutrino MP3 492.7 AK, 2013 Moto Guzzi Norge
Joined: 29 Mar 2008
Posts: 21665
Location: Harriman, Tennessee, Tn
Sat Jul 16, 2016 3:30 am quote
your low on coolant.
Veni, Vidi, Posti
MP3 500, GTS 250 (both 2008 MY), 2012 Honda NC700 DCT
Joined: 02 Mar 2013
Posts: 6127
Location: Madison, Wisconsin
Sat Jul 16, 2016 3:55 am quote
old as dirt wrote:
your low on coolant.

I had no idea this warning existed!
Cool....
Member
Piaggio Mp3 2009
Joined: 16 Jul 2016
Posts: 5
Location: Slovakia
Sat Jul 16, 2016 4:50 am quote
old as dirt wrote:
your low on coolant.
Not sure, yesterday I tried to full it, did not help :/ but thanks for help
Ossessionato
2016 MP3/500 Sport ABS, 2009 MP3/250, 2012 GTS Super 300ie
Joined: 08 Jul 2011
Posts: 4295
Location: Marietta, GA
Sat Jul 16, 2016 5:18 am quote
paN wrote:
old as dirt wrote:
your low on coolant.
Not sure, yesterday I tried to full it, did not help :/ but thanks for help
Be careful with that, not having adequate coolant can cost you a engine.
There is a process to follow to get the Air out, do your research.

If its been two years, you need to flush and re-fill with the Red/Pink AGIP Coolant.

Keith,
Marietta, GA
Veni, Vidi, Posti
Neutrino MP3 492.7 AK, 2013 Moto Guzzi Norge
Joined: 29 Mar 2008
Posts: 21665
Location: Harriman, Tennessee, Tn
Sat Jul 16, 2016 5:53 am quote
I might be mistaken on the coolant it could be the outside temp is below or close to freezing.
Veni, Vidi, Posti
MP3 500, GTS 250 (both 2008 MY), 2012 Honda NC700 DCT
Joined: 02 Mar 2013
Posts: 6127
Location: Madison, Wisconsin
Sat Jul 16, 2016 6:07 am quote
old as dirt wrote:
I might be mistaken on the coolant it could be the outside temp is below or close to freezing.
Could be, but for some reason I recall it saying "ICE" when it is cold out.
Veni, Vidi, Posti
MP3 500, GTS 250 (both 2008 MY), 2012 Honda NC700 DCT
Joined: 02 Mar 2013
Posts: 6127
Location: Madison, Wisconsin
Sat Jul 16, 2016 6:08 am quote
That, and the weather in Slovakia right now is nowhere near freezing, so if that's a pic of a freshly purchased scooter, probably not an ice warning.
Hooked
None at present
Joined: 21 Jul 2015
Posts: 462
Location: Hill Of Beath, Fife
Sat Jul 16, 2016 7:41 am quote
I thought the scooter was being polite and greeting you. L O (hello) Don't worry I'll get my coat on the way out
Ossessionato
2016 MP3/500 Sport ABS, 2009 MP3/250, 2012 GTS Super 300ie
Joined: 08 Jul 2011
Posts: 4295
Location: Marietta, GA
Sat Jul 16, 2016 8:35 am quote
old as dirt wrote:
I might be mistaken on the coolant it could be the outside temp is below or close to freezing.
That's not happening here in Atlanta...
Time to read the Manual.
I have never seen LO before, that was a knew one on me.

I just searched for LO in the User Shop Manuals. Nothing...
Hooked
2019 MP3 500hpe Sport
Joined: 03 Nov 2014
Posts: 472
Location: Germany
Sat Jul 16, 2016 12:45 pm quote
it is 07 degrees. it is just upside down.

i did a google search really quickly and came back with nothing other than another post on here from 2009 or 10.
Ossessionato
2016 MP3/500 Sport ABS, 2009 MP3/250, 2012 GTS Super 300ie
Joined: 08 Jul 2011
Posts: 4295
Location: Marietta, GA
Sat Jul 16, 2016 2:10 pm quote
new200guy wrote:
it is 07 degrees. it is just upside down.

i did a google search really quickly and came back with nothing other than another post on here from 2009 or 10.
Ok, I can accept that being upside down, but what about the other digits on the same LCD Panel, they aren't upside down. I spent an hour or so on this, it had me so curious I gave up looking.

Keith,
Marietta, GA
Member
Piaggio Mp3 2009
Joined: 16 Jul 2016
Posts: 5
Location: Slovakia
Sat Jul 16, 2016 10:06 pm quote
old as dirt wrote:
I might be mistaken on the coolant it could be the outside temp is below or close to freezing.
There was 35 degree and it said LO


I just did not try to take the air out of engine and intercooler system, but as far as I know, it is done by itselft (automatically)

Or if not helps, try to change all watter there.
Member
Piaggio Mp3 2009
Joined: 16 Jul 2016
Posts: 5
Location: Slovakia
Sat Jul 16, 2016 10:10 pm quote
sixpence wrote:
I thought the scooter was being polite and greeting you. L O (hello) Don't worry I'll get my coat on the way out
Ehmm, OK hope so then I go to the garage and appologize and ask for temperature info you know it says all the time when it is running

Thanks for idea
Member
Piaggio Mp3 2009
Joined: 16 Jul 2016
Posts: 5
Location: Slovakia
Sat Jul 16, 2016 10:11 pm quote
klaborde wrote:
old as dirt wrote:
I might be mistaken on the coolant it could be the outside temp is below or close to freezing.
That's not happening here in Atlanta...
Time to read the Manual.
I have never seen LO before, that was a knew one on me.

I just searched for LO in the User Shop Manuals. Nothing...
Thanks for time, I tried to search it in manuals, nothing
Ossessionato
2009 MP3 400
Joined: 27 Jul 2008
Posts: 2008
Location: Saratoga, N.Y.
Mon Jul 18, 2016 6:49 am quote
paN wrote:
I just did not try to take the air out of engine and intercooler system, but as far as I know, it is done by itselft (automatically)
You do need to burp it manually. It's covered in the service manual (available via link in the wiki) and quite easy.

Last edited by ramblerdan on Wed Jul 20, 2016 5:26 am; edited 1 time in total
Ossessionato
Scarabeo 500GT(hers), `07 250 MP3, `09 400 MP3
Joined: 13 Oct 2008
Posts: 2592
Location: Kingman, Az.
Tue Jul 19, 2016 8:56 pm quote
When I was riding my 400 MP3 in high temp conditions the temp gauge went from reading 123F to HI when the temp I assume hit 124F. So at least on the high side the temp gauge only reads accurately to a certain point. If it was really cold in Slovakia maybe that's why it read LO.
Lurker
MP3 500ie
Joined: 09 Sep 2020
Posts: 3
Location: 08540
Wed Sep 09, 2020 1:03 pm quote
"LO"?????
my 2009 mp3 500 shows "LO" where it usually reads the outside ambient temp. any idea why? i never saw an answer to the original post...

119058530_614658609198577_5353540101637702676_n.jpg

Hooked
Piaggio MP3 500
Joined: 21 Nov 2017
Posts: 276
Location: Austin, TX
Thu Sep 10, 2020 7:07 am quote
For 2009, you only have 6900 miles, it means that your mileage is LO, you need to get out and ride more.

I suspect it's a problem with the temperature sensor or its connections. The sensor is located under the leg shield, and it can get covered with road debris and dirt and water, and the connections can go bad. Find it, clean it off and grease the connections with some dielectric grease, and it will probably start working again.
Ossessionato
Gilera Fuoco 500ie
Joined: 11 Oct 2009
Posts: 4196
Location: Netherlands Olst
Thu Sep 10, 2020 12:47 pm quote
coollant or air in the system or temp sensor kaputt
Hooked
50cc Beo, BigBeo
Joined: 30 May 2015
Posts: 262
Location: Chelyabinsk, Russia
Thu Sep 10, 2020 6:56 pm quote
This temp is read not from head temp sensor, but from riders' right knee. So no coolant there (unless spilled on their pants).
Member
Gilera Fuoco
Joined: 13 Aug 2020
Posts: 20
Location: Russia
Fri Sep 11, 2020 2:37 am quote
Re: "LO"?????
jromeo350420 wrote:
my 2009 mp3 500 shows "LO" where it usually reads the outside ambient temp. any idea why? i never saw an answer to the original post...
Don't look for logic in Piaggio's actions
For example, how would you like to sound 5 beeps when there is a pressure problem in the tilt lock system? It doesn't make any sense, but it exists ...

Based on my complete lack of experience with Italian technique, I agree with Squeazel's idea, and I assume that the wire to the ambient temperature sensor is open or short in this line.
Hooked
50cc Beo, BigBeo
Joined: 30 May 2015
Posts: 262
Location: Chelyabinsk, Russia
Fri Sep 11, 2020 8:46 am quote
If you ever had a will to read manual, 5 beeps would make sense for you
Member
Gilera Fuoco
Joined: 13 Aug 2020
Posts: 20
Location: Russia
Fri Sep 11, 2020 8:49 am quote
In the manual can describe any crazy thing to cover ass...
Hooked
50cc Beo, BigBeo
Joined: 30 May 2015
Posts: 262
Location: Chelyabinsk, Russia
Fri Sep 11, 2020 9:15 am quote
Those 5 beeps are totally fine for anyone around the world, what's wrong with them for you?
Veni, Vidi, Posti
2008 MP3 500, 2013 BV350, 2020 Vespa Sei Giorni
Joined: 13 Oct 2012
Posts: 8626
Location: Ashburn, Va. Home to the Internet
Fri Sep 11, 2020 2:48 pm quote
Mine does that when the outside temp is below freezing. It is letting you know it is cold enough for water on the road to freeze.
Member
Gilera Fuoco
Joined: 13 Aug 2020
Posts: 20
Location: Russia
Fri Sep 11, 2020 10:31 pm quote
WEB-Tech wrote:
Mine does that when the outside temp is below freezing. It is letting you know it is cold enough for water on the road to freeze.
This is more believable, than coolant volume...
Lurker
MP3 500ie
Joined: 09 Sep 2020
Posts: 3
Location: 08540
Thu Sep 17, 2020 2:56 pm quote
Well I filled up the coolant and the reading did not go away also the outside temperature is around 80 degrees Fahrenheit so it's not an outside temperature warning from the temperature being too low so this is really got my head spinning I called dealerships and even they can't give me an answer. This is really weird and if anyone could give me an answer on why it's reading "LO" I would really appreciate it because at this point I'm scared to keep riding it without knowing what the issue is
Moderaptor
The Hornet (GT200, aka Love Bug) and 'Dimples' - a GTS 300
Joined: 26 Aug 2007
Posts: 38887
Location: Pleasant Hill, CA
Thu Sep 17, 2020 3:21 pm quote
Don't be scared of riding it. It can only be a faulty sensor, or more likely the connection to it. This is only the ambient temperature reading after all! That's of big consequence to the engine, thought it might take it into account to in its air-mass calculations.
Hooked
50cc Beo, BigBeo
Joined: 30 May 2015
Posts: 262
Location: Chelyabinsk, Russia
Thu Sep 17, 2020 8:31 pm quote
I guess ECU takes into account the other sensor, which is located in throttle body. Simply because it is more accurate to real temp of intake air.
Cross Egypt Challenge - A 2400km ride throughout Egypt   vespa scooterwest scooter west Motorsport Scooters   AF1 Racing Vespa Austin
Post Reply    Forum -> MP3 Discussion
[ Time: 0.1766s ][ Queries: 27 (0.0451s) ][ Debug on ]