URGENT: GTS 300 Super ABS-Low pressure light with loud sound
Post Reply    Forum -> General Discussion
Author Message
Member
Vespa GTS Super Sport 300
Joined: 22 Dec 2015
Posts: 11
Location: Singapore
Mon Sep 10, 2018 4:06 pm quote
HI,

After i had my bike service, changed engine oil, oil filter ,changed coolant, valve clearance and i also had my oil pan, water pump cover and belt cover power coated. After its done, i tested it and the engine run super quiet and smooth. Thus i rode back home which is 10kms away, however there is this strange mettalic clickig sound that rises and falls with the revs (i have akropovic exhaust on) and all i could hear is this clicking reving sound and it sound rough, then i notice my oil pressure light was lighted. i immediately switch off my engine and let it rest, all this time there is no over heating light warning. then i switch it back on n rode home and the light came on again. When i got home, i tried to listen to where the sound is coming from, it seems louder at the water pump side. Its as if there is something stuck in some spinner inside. But damn, it sounded loud n rough.
Brought it back to the bike shop, drained the oil and open up the oil pan, everything seems normal, but the oil filter catridge seems to have like some sticky pulp like those paper pulp, nothing that is metal , or metal shavings. Filled back with oil and the sound still remains. Guess next could be oil pump check.

Does anyone have experience with this?
Ossessionato
09 190s taormina
Joined: 08 Apr 2010
Posts: 2045
Location: Googleville
Mon Sep 10, 2018 6:50 pm quote
yummyburger wrote:
had my oil pan, water pump cover and belt cover power coated.
There's a oil check valve and spring behind the sump cover you had powdercoated. Did these get reinstalled correctly?
Member
Vespa GTS Super Sport 300
Joined: 22 Dec 2015
Posts: 11
Location: Singapore
Wed Sep 12, 2018 12:31 am quote
yup, thats the valve with the spring. Opened up n tear down the oil pump . Checked the chain and pump, all moving smoothly, no seize whatever. Put everything back n start the engine. After a while the light came back on and rough sound still there, meaning there isnt enough oil getting to the crank. Last possible culprit probably oil passage way. Anyone have experience with this?
Member
Vespa GTS Super Sport 300
Joined: 22 Dec 2015
Posts: 11
Location: Singapore
Thu Sep 13, 2018 7:59 pm quote
ok am pretty sure the mechanic left the masking tape in the oil pan when they took back from powder coating.
Cross Egypt Challenge - A 2400km ride throughout Egypt   Vespa Wasp Pin Badges   Cool Ass scooter seat cover
Post Reply    Forum -> General Discussion
[ Time: 0.5271s ][ Queries: 23 (0.0568s) ][ Debug on ]