2009 MP3 400ie wont start
Post Reply    Forum -> MP3 Discussion
Author Message
Enthusiast
2009 MP3 400ie
Joined: 31 May 2016
Posts: 55
Location: philippines
Tue Dec 11, 2018 9:19 pm quote
Hello guys im here at my work place 2009 Mp3 400 wont start... after cranking then release check engine light comes on..checked all fuses all good. any help would be appreciated
Enthusiast
Gilera Fuoco
Joined: 17 Sep 2017
Posts: 91
Location: Birmingham, England
Wed Dec 12, 2018 3:12 pm quote
Check that some joker hasn't activated the 'Kill' switch.

Remove and refit the fuel cap, to eliminate a vacuum lock.

If you have the tools, check you have a spark at the plugs.
Hooked
MP3-400 + Honda NT650V Deauville
Joined: 06 Apr 2011
Posts: 393
Location: Auckland New Zealand
Wed Dec 12, 2018 4:13 pm quote
When you turn the key to "On", do you hear the fuel pump 'whirring' as it pressurizes the fuel system? If not, then it could be the fuel pump relay has failed and it is one of the relays under the front panel behind the screen.
Enthusiast
2009 MP3 400ie
Joined: 31 May 2016
Posts: 55
Location: philippines
Thu Dec 13, 2018 12:11 pm quote
thank you guys
Took my bike to a vespa mechanic.. he just sprayed contact cleaners to the fuse boxes one near the foot board and the other next to the battery and he replaces the fuses with new once.. now its working. he said my bike is 9yrs old so theres built up of that hard white stuff on the terminals that sometimes looses electrical contact. Hopefully thats it... will try to see. Thank you guys for sharing I will definitely keep those in mind in case it acted out again.
2019 Spring Gathering - May 16 - 19, Location TBD (Likely Maggie Valley, NC)   vespa scooterwest scooter west Motorsport Scooters   AF1 Racing Vespa Austin
Post Reply    Forum -> MP3 Discussion
[ Time: 0.1926s ][ Queries: 23 (0.0302s) ][ Debug on ]