hi everybody i am new here MP3 Problem
Post Reply    Forum -> MP3 Discussion
Author Message
Member
MP3 500 sport abs 2014
Joined: 27 May 2019
Posts: 13
Location: Eastleigh
Mon May 27, 2019 7:48 pm quote
hi i bought a MP3 500 sport ABS 2014 with a shot engine i have changed the engine for a very low miles one
because i have never had it running till now amazingly it started first time but will only tick over, is it because of the seat switch because i have not fitted the panels or seat yet
when it starts the ABS and ASR lights are flashing and i thought i had a problem but i have found they flash till you go over 5 mph
a big thanks in advance Bill
Hooked
Joined: 06 Nov 2014
Posts: 271
Location: Uk rochdale
Mon May 27, 2019 10:25 pm quote
hello bill and welcome, yes fella without seat sensor will only go to rev but be limited. ask us another question.
Member
MP3 500 sport abs 2014
Joined: 27 May 2019
Posts: 13
Location: Eastleigh
Tue May 28, 2019 12:54 pm quote
hi Buddy
hi thanks for the reply, i see you are in the UK also where may i ask?
Do you ride a MP3
Hooked
Joined: 06 Nov 2014
Posts: 271
Location: Uk rochdale
Tue May 28, 2019 11:15 pm quote
no problems bill we are all here for the same reason. we suck at choosing our rides I was until last year living in south east London, but I now reside in sunny Rochdale I currently have a small 250 mp3 but wish I had kept the piaggio x10 I sold a few months ago.
Member
MP3 500 sport abs 2014
Joined: 27 May 2019
Posts: 13
Location: Eastleigh
Sun Jun 02, 2019 9:52 pm quote
up date
hi i put a 3.3k resistor to take care of the seat switch stripped of the rest of the pannels to check and clean the tilt lock, removed the speed sensors cleaned and checked them. It will start first time the abs and asr lights both flash together the large tilt light flashes and if you switch switch on the tilt lock the other tilt lock light comes on
with the tilt lock on it will only rev to exactly 2000 and with the tilt lock off it will rev to 2500 and up to 3000 but fluctuating like trying to rev higher
the battery is showing 12.7v and 14 when running
the cover is off the air filter could that make a differance
i removed and cleaned the spark plugs,
drained the fuel and put in new fuel
is there a fuel filter anywhere??
i can feel the fuel pump pumping

Next i am going to remove the fuel injector and have a good look at the throttle body
ANY IDEAS ANYONE
Member
MP3 500 sport abs 2014
Joined: 27 May 2019
Posts: 13
Location: Eastleigh
Sun Jun 02, 2019 11:15 pm quote
found this
could this be why it will not rev on the stand

N.B.THE DEVICE PREVENTS IMPRESSING ON THE REAR HIGH SPEED ROTATIONWHEEL WITH THE VEHICLE ON THE CENTRE STAND. IT IS RECOMMENDEDNOT TO INSIST WITH THE THROTTLE GRIP IN THIS PARTICULAR CONDITION.
Missouri Loves Company Rally   Vespa Wasp Pin Badges   AF1 Racing Vespa Austin
Post Reply    Forum -> MP3 Discussion
[ Time: 0.1481s ][ Queries: 23 (0.0479s) ][ Debug on ]