Tacho acting weard
Post Reply    Forum -> Not-So-Modern
Author Message
Enthusiast
Vespa cosa 200
Joined: 04 Jun 2018
Posts: 74
Location: Wilderen-Belgium
Mon Jul 08, 2019 1:26 am quote
Hey guys,
After my rebuild i have a strange thing with my tacho.
I replaced the wire and now some times my tacho works sometimes not.
Is my wire not placed good or do i need to replace the mechanism in the wheel also?
Thanks!
Veni, Vidi, Posti
74 50s x2 78 P200 84 Cosa 58 AllState 68 Sprint 80 50special + projects
Joined: 22 Nov 2010
Posts: 6882
Location: seattle/athens
Mon Jul 08, 2019 9:01 am quote
Ahhh... you mean speedometer, not the tachometer(Cosa has both). And you mean speedometer cable, not wire I think. If the speedo cable is connected properly at the front wheel & the gears in the hub are OK, then you should be able to remove the speedo and watch the end of the cable at the top end to see if it turns when you spin the front wheel.

If it sometimes works and sometimes not, then the square ends of the cable may not be fully engaged in either the gear down below or in the speedometer connection underneath. Or the plastic gear at the bottom end could be damaged.

Last edited by V oodoo on Mon Jul 08, 2019 1:19 pm; edited 1 time in total
Enthusiast
Vespa cosa 200
Joined: 04 Jun 2018
Posts: 74
Location: Wilderen-Belgium
Mon Jul 08, 2019 12:37 pm quote
Thats what i mean thank you V oodoo!
Sorry sometimes i mix up my words in english
Missouri Loves Company Rally   vespa scooterwest scooter west Motorsport Scooters   Yelcome Leather Top Cases and Roll Bags for Piaggio Vespa PX LX LXV GTS GTV
Post Reply    Forum -> Not-So-Modern
[ Time: 0.6459s ][ Queries: 23 (0.1041s) ][ Debug on ]