faco gt200 rear rack
Post Reply    Forum -> General Discussion
Author Message
Hooked
2005 gt200
Joined: 07 Nov 2005
Posts: 211
Location: upstate NY
Thu Mar 30, 2006 3:37 pm quote
I purchased a Faco rear rack for my GT. The weld quality and finish work on the rack are down right horrendous. You can literally cut yourself on the welds they are so rough. Does anyone else have this rack with such poor craftmanship? It's not a cheap rack to purchase and I am feeling a bit ripped off due to the low quality.
Any suggestions?

Hope everyone is enjoying the Spring riding weather.
Veni, Vidi, Posti
Yamaha Vstar classic 650 'Yamama' (Currently waspless but don't count me out!)
Joined: 06 Feb 2006
Posts: 6723
Location: Maple Grove, MN
Thu Mar 30, 2006 5:19 pm quote
I got the Faco rear rack with the backrest for my GT and the workmanship is very good. The worst complaint I have is how much force it took to separate the side arms to get them in place while mounting it. It's been rock solid since I put it on too. I use it as a handle to move the bike around.
Hooked
2005 gt200
Joined: 07 Nov 2005
Posts: 211
Location: upstate NY
Thu Mar 30, 2006 5:24 pm quote
It's crazy how horrible the welds are. Doesn't affect the functionality of the rack- it just looks like hell. I guess that is the risk of mail order.
Ossessionato
None! I sold it :(
Joined: 01 Nov 2005
Posts: 3247
Location: Burlington NC
Fri Mar 31, 2006 2:33 am quote
ek wrote:
It's crazy how horrible the welds are. Doesn't affect the functionality of the rack- it just looks like hell. I guess that is the risk of mail order.
Did you buy from e-bay, or a known company? If you bought it from a known company, call them, send it back, exchange it? I have done all of these in the past with good results. You might be suprised what they say. Most want to keep a good name, can not hurt to try, Beale.
Rallies Europe 2016   vespa scooterwest scooter west Motorsport Scooters   AF1 Racing Vespa Austin
Post Reply    Forum -> General Discussion
[ Time: 0.3178s ][ Queries: 23 (0.0448s) ][ Debug on ]