Sat Sep 11, 2021 2:21 pm

Lurker
Piaggio MP3 250
Joined: 11 Sep 2021
Posts: 2
Location: Wigan
 
Lurker
Piaggio MP3 250
Joined: 11 Sep 2021
Posts: 2
Location: Wigan
Sat Sep 11, 2021 2:21 pm linkquote
My MP3 (250) has recently developed a problem and I wondered if anyone has experienced similar issues. The bike idles fine, but splutters when revving and has no power to move forward. This happened a couple of times at traffic lights, but I was able to switch off and start again and continue my journey. However the problem is now constant (it starts and idles no problem, but will not move). I'd be grateful for any help and advice. Many thanks.
Sat Sep 11, 2021 8:42 pm

Addicted
2015 MP3 500 ie Business
Joined: 29 Oct 2019
Posts: 565
Location: Belgium
 
Addicted
2015 MP3 500 ie Business
Joined: 29 Oct 2019
Posts: 565
Location: Belgium
Sat Sep 11, 2021 8:42 pm linkquote
I'd start with a new air filter, fuel filter and a set of plugs. Also check to make sure all clamps, such as those from the airbox going to the throttle body are tight and not cracked.

Cheap and cheerful first.
Sun Sep 12, 2021 12:46 am

Ossessionato
Gilera Fuoco 500ie
Joined: 11 Oct 2009
Posts: 4329
Location: Netherlands Olst
 
Ossessionato
Gilera Fuoco 500ie
Joined: 11 Oct 2009
Posts: 4329
Location: Netherlands Olst
Sun Sep 12, 2021 12:46 am linkquote
is it on the lock ?
Sun Sep 12, 2021 3:00 am

Lurker
Piaggio MP3 250
Joined: 11 Sep 2021
Posts: 2
Location: Wigan
 
Lurker
Piaggio MP3 250
Joined: 11 Sep 2021
Posts: 2
Location: Wigan
Sun Sep 12, 2021 3:00 am linkquote
Thank you for getting back to me. I've checked the air filter, plugs and cables and they all seem to be fine.

I've been trying to start from the locked (rigid) position, as I always pull away in this way.

It idles fine, but bangs and shakes the engine and exhaust when I start to rev. There doesn't seem to be exhaust fumes, just a smell of petrol, if that helps.
Sun Sep 12, 2021 6:41 am

Moderaptor
The Hornet (GT200, aka Love Bug) and 'Dimples' - a GTS 300
Joined: 26 Aug 2007
Posts: 40391
Location: Pleasant Hill, CA
 
Moderaptor
The Hornet (GT200, aka Love Bug) and 'Dimples' - a GTS 300
Joined: 26 Aug 2007
Posts: 40391
Location: Pleasant Hill, CA
Sun Sep 12, 2021 6:41 am linkquote
While stationary, unlock the suspension - if it now rides off just fine you've got a problem with the seat sensor. You can bypass this with a 3kohm resistor.
Sun Sep 12, 2021 6:24 pm

Moderatus Rana
MP3 250 and 2 MP3 500s
Joined: 11 Jul 2008
Posts: 22154
Location: Nashville, Indiana
 
Moderatus Rana
MP3 250 and 2 MP3 500s
Joined: 11 Jul 2008
Posts: 22154
Location: Nashville, Indiana
Sun Sep 12, 2021 6:24 pm linkquote
Yep I was going to say what Jim said. Had this issue myself.
  DoubleGood Vespa Design  

All Content Copyright 2005-2021 by Modern Vespa. All Rights Reserved.

Modern Vespa is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com.

Shop on Amazon Smile with Modern Vespa

[ Time: 0.0295s ][ Queries: 5 (0.0087s) ][ Debug on ][ 209 ][ Thing One ]