Tue Oct 12, 2021 9:31 am

Lurker
Piaggio MP3 250
Joined: 12 Oct 2021
Posts: 3
Location: Finland
 
Lurker
Piaggio MP3 250
Joined: 12 Oct 2021
Posts: 3
Location: Finland
Tue Oct 12, 2021 9:31 am linkquote
Hi! I got an MP3 250 (2007) for commute, coming up to the 10k km mark and getting ready for winter. I'm taking my scoot to the local shop for all the maintenance, and I'm trying to make a list of everything that I want them to check that isn't on the mileage check list already, but I'm new to owning vehicles like this.

So, what's something obvious that a complete newbie like me would probably miss about winter prep? Oil and coolant are getting replaced with something suitable for freezing weather (it can get as low as -20C, but at that point I suspect I'll be carpooling with coworkers), but what about the other fluids? I'm also getting a battery tender, I've got new driving overalls and obviously new tyres, but is there something obvious about driving in the winter season that I should be prepared for?

Second, maybe I missed it in a thread, but does anyone know if the seat sensor error tone is continuous? The tilt lock if it behaves itself during a drive, but when I lock it at a stop, both the red warning light and the yellow indicator light up solid, and there's a constant tone, no beeping or honking. For context, I'd had the "red light lights up and after taking off, revs limited to 2000rpm, steady slow beeping" problem before, which turned out to be an issue with one of the sensor cables having gotten jangled, so it would error out every time I hit even the slightest bump. Fluid levels are fine, and the front locks correctly and doesn't slip even with vigorous shaking, but it can only be unlocked with the doubletap. It doesn't interfere with my commute, I'm pretty adept at manoeuvring the scoot without the front locked, but I'd like to give the shop an opportunity to fix it.

A few weeks back I got caught in a really bad rainstorm and my scoot died on the way home. The culprit turned out to be the air filter, which has since been switched out, but we did sit out in the rain for quite a bit waiting for a tow truck so I wouldn't be surprised if there's a bunch of shit gone wrong with the electronics.
Tue Nov 02, 2021 7:39 am

Lurker
Piaggio MP3 250
Joined: 12 Oct 2021
Posts: 3
Location: Finland
 
Lurker
Piaggio MP3 250
Joined: 12 Oct 2021
Posts: 3
Location: Finland
Tue Nov 02, 2021 7:39 am linkquote
Update on this -- the week before I was taking the scoot in, I suddenly got the slow beep error I had when I had bumped the sensor at the wheel, but as I was slowing down, the tone turned into the continuous tone and the RPM limiter turned on. While the bike has been sitting in their storage, it has gone back and forth between the continuous tone and the slow beep, occasionally working fine, occasionally turning the limiter on. The only constant thing is that if you try to force-unlock the tilt lock, you can hear the lock disengaging. It's been successfully disengaged, but it won't turn back on. Now I wish I had checked if revving turned off the lock while I was still having the "continuous tone while locked, works fine when forcefully unlocked" problem.

Also turns out there's no longer an importer in my country, and so the shop doesn't have a tester and no idea where to get started, so they're quoting me full diagnostic price at the moment. Well, shit. I'll probably have to have the scoot moved into winter storage so I can take a look at it myself at this rate. I managed to find the beep code video elsewhere in this forum, and I need to check, and the beeping pattern is definitely the slower one, although IIRC it's even slower than the 2.5s example -- it starts with a continuous tone that goes on for a good bit before switching to the slow beep. I have no idea how jangling the cable back into place fixed it previously, maybe there was an overlapping problem and I just got lucky.

Still taking suggestions on winter prep, too Helps to keep positive, hopefully she doesn't have to sit the entire four months.
Tue Nov 02, 2021 9:08 am

Lurker
Piaggio MP3 250
Joined: 12 Oct 2021
Posts: 3
Location: Finland
 
Lurker
Piaggio MP3 250
Joined: 12 Oct 2021
Posts: 3
Location: Finland
Tue Nov 02, 2021 9:08 am linkquote
Had a sit-down to browse the forum, and lo and behold -- this behaviour is a lot like the problem I was having before I got stranded:

https://modernvespa.com/forum/post1394899#1394899

I'm probably gonna have the scoot moved to winter storage the next town over and tell them to check the potentiometer. I won't have a chance to get to it for a while, but seems like as good as place as any to start in the absence of any kind of diagnostic options. I'm extremely bummed out, there's quite a lot of Piaggio bikes around so I blindly believed that someone had to be maintaining them, but apparently that was overly trusting of me

Another thing, I called up the previous owner and they'd actually replaced the ECU before. I really hope the scoot doesn't chew through those things, they do not come cheap.
  DoubleGood Vespa Design  

All Content Copyright 2005-2021 by Modern Vespa. All Rights Reserved.

Modern Vespa is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com.

Shop on Amazon Smile with Modern Vespa

[ Time: 0.0270s ][ Queries: 5 (0.0072s) ][ Debug on ][ 209 ][ Thing One ]