Sat Jun 11, 2022 3:55 pm

Member
Piaggio MP3
Joined: 04 Jun 2022
Posts: 8
Location: Santa Rosa Beach
 
Member
Piaggio MP3
Joined: 04 Jun 2022
Posts: 8
Location: Santa Rosa Beach
Sat Jun 11, 2022 3:55 pm linkquote
Folks I have a 2008 mp3 400
Where is the CDI located?pics would help
I have no spark and want to try testing the CDI but I have no clue what it looks like
Sat Jun 11, 2022 4:02 pm

Moderaptor
The Hornet (GT200, aka Love Bug) and 'Dimples' - a GTS 300
Joined: 26 Aug 2007
Posts: 41203
Location: Pleasant Hill, CA
 
Moderaptor
The Hornet (GT200, aka Love Bug) and 'Dimples' - a GTS 300
Joined: 26 Aug 2007
Posts: 41203
Location: Pleasant Hill, CA
Sat Jun 11, 2022 4:02 pm linkquote
vasile.infinityair wrote:
Folks I have a 2008 mp3 400
Where is the CDI located?pics would help
I have no spark and want to try testing the CDI but I have no clue what it looks like
The ECU is an integral part of the throttle body. No separate CDI.
Sat Jun 11, 2022 4:05 pm

Member
Piaggio MP3
Joined: 04 Jun 2022
Posts: 8
Location: Santa Rosa Beach
 
Member
Piaggio MP3
Joined: 04 Jun 2022
Posts: 8
Location: Santa Rosa Beach
Sat Jun 11, 2022 4:05 pm linkquote
jimc wrote:
The ECU is an integral part of the throttle body. No separate CDI.
Where should I start checking then?
I have no spark
My key works so it's not the immobilizer
Checked all fuses
Kill switch works
Fuel pump and starter both engage
Any help would be much appreciated
Sat Jun 11, 2022 9:39 pm

Addicted
2015 MP3 500 ie Business
Joined: 29 Oct 2019
Posts: 814
Location: Belgium
 
Addicted
2015 MP3 500 ie Business
Joined: 29 Oct 2019
Posts: 814
Location: Belgium
Sat Jun 11, 2022 9:39 pm linkquote
Does the red CODE light stay on? If so, then it is the immobilizer that is preventing power to the coil and hence no spark.
Sat Jun 11, 2022 9:44 pm

Member
Piaggio MP3
Joined: 04 Jun 2022
Posts: 8
Location: Santa Rosa Beach
 
Member
Piaggio MP3
Joined: 04 Jun 2022
Posts: 8
Location: Santa Rosa Beach
Sat Jun 11, 2022 9:44 pm linkquote
sbaert wrote:
Does the red CODE light stay on? If so, then it is the immobilizer that is preventing power to the coil and hence no spark.
Red light goes off as normal operation
Just like the manual says
Red light comes one when key in On position and the goes off and no blinking lights so I think that's not the issue
Sun Jun 12, 2022 9:55 am

Moderaptor
The Hornet (GT200, aka Love Bug) and 'Dimples' - a GTS 300
Joined: 26 Aug 2007
Posts: 41203
Location: Pleasant Hill, CA
 
Moderaptor
The Hornet (GT200, aka Love Bug) and 'Dimples' - a GTS 300
Joined: 26 Aug 2007
Posts: 41203
Location: Pleasant Hill, CA
Sun Jun 12, 2022 9:55 am linkquote
I'm assuming you've tested for no spark by using a spare plug attached to the cap, and checked the wire and cap are firmly screwed in at each end.

Check the coil for continuity to the ECU, and for resistance values as outlined in the workshop manual.
  DoubleGood Vespa Design  

All Content Copyright 2005-2022 by Modern Vespa. All Rights Reserved.

Modern Vespa is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com.

Shop on Amazon Smile with Modern Vespa

[ Time: 0.0294s ][ Queries: 5 (0.0100s) ][ Debug on ][ 211 ][ Thing One ]