OP
@big-7-baz avatar
UTC

Addicted
AUTO. & TRAD.
Joined: UTC
Posts: 805
Location: 7-oaks England
 
Addicted
@big-7-baz avatar
AUTO. & TRAD.
Joined: UTC
Posts: 805
Location: 7-oaks England
UTC quote
It won't go!!!
No spark and no flashing led.
Tried another cdi and no change, the led doesn't do anything...
So if it's not the cdi has anyone got any idea what it could be?
@amoffski avatar
UTC

Member
vespa et4
Joined: UTC
Posts: 47
Location: glasgow
 
Member
@amoffski avatar
vespa et4
Joined: UTC
Posts: 47
Location: glasgow
UTC quote
re no spark
have a look at hte fuse under the seat / if not that have a look at your imobiliser { there are ways on the net on how to bypass it } also cheack the ht lead , plug cap ect to make sure it is connected properly {unlikely tho}
@drewteague avatar
UTC

Ossessionato
Joined: UTC
Posts: 2813
Location: Austin
 
Ossessionato
@drewteague avatar
Joined: UTC
Posts: 2813
Location: Austin
UTC quote
There's a good chance it's related to the RPM pickup on the flywheel. There is a magnetic sensor (built into the stator assembly) that detects a raised section on the outer face of the magneto. If one or both becomes corroded, the ECU doesn't know where TDC is and won't fire the plug. Occasionally cleaning the corrosion with a wire brush and setting the gap will do the trick. Otherwise, the bad part(s) must be replaced.
DoubleGood Design banner

Modern Vespa is the premier site for modern Vespa and Piaggio scooters. Vespa GTS300, GTS250, GTV, GT200, LX150, LXS, ET4, ET2, MP3, Fuoco, Elettrica and more.

Buy Me A Coffee
 

Shop on Amazon with Modern Vespa

Modern Vespa is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com


All Content Copyright 2005-2024 by Modern Vespa.
All Rights Reserved.


[ Time: 0.0292s ][ Queries: 3 (0.0065s) ][ Debug on ][ 313 ][ Thing One ]