OP
@schultz avatar
UTC

Hooked
GTS 300
Joined: UTC
Posts: 109
Location: Cistern,Tx
 
Hooked
@schultz avatar
GTS 300
Joined: UTC
Posts: 109
Location: Cistern,Tx
UTC quote
Engine Control Light came on when I was decelerating 140 miles on it. Running like normal. Just filled it up with gas to the top but fuel gauge still had one more bar to go hmmmmm. When I got it home from dealer tank was full to top and all bars were showing on gauge. I will see what it does tomorrow when I start it. If engine control light comes on agin I will disconnect battery for a while and see if that clears it. And suggestions.
@jet_peddler avatar
UTC

Veni, Vidi, Posti
'07 LX150 (Sold), '17 GTS300, '16 BV350, '15 EN650, '09 FXDF (sold). '15 FLSTN
Joined: UTC
Posts: 5664
Location: Home of the Alamo
 
Veni, Vidi, Posti
@jet_peddler avatar
'07 LX150 (Sold), '17 GTS300, '16 BV350, '15 EN650, '09 FXDF (sold). '15 FLSTN
Joined: UTC
Posts: 5664
Location: Home of the Alamo
UTC quote
GTS 250?
@old_as_dirt avatar
UTC

Veni, Vidi, Posti
2007 GTS
Joined: UTC
Posts: 22490
Location: Harriman, Tennessee, Tn
 
Veni, Vidi, Posti
@old_as_dirt avatar
2007 GTS
Joined: UTC
Posts: 22490
Location: Harriman, Tennessee, Tn
UTC quote
thats the early trade in light. once it comes on you have 90 days to get it traded in. After that your on your own. Laughing emoticon
OP
@schultz avatar
UTC

Hooked
GTS 300
Joined: UTC
Posts: 109
Location: Cistern,Tx
 
Hooked
@schultz avatar
GTS 300
Joined: UTC
Posts: 109
Location: Cistern,Tx
UTC quote
Ya right dam high tech emission grap they put on em now days. Ti is 2018 GTS 300
OP
@schultz avatar
UTC

Hooked
GTS 300
Joined: UTC
Posts: 109
Location: Cistern,Tx
 
Hooked
@schultz avatar
GTS 300
Joined: UTC
Posts: 109
Location: Cistern,Tx
UTC quote
Back to AF1
Disconnect battery this morning for probably 15 mins. Connect it back up and start it and engine control light is still on. Notice it was idling ruff. Gave it some throttle and the worse it got. So have to load it back in truck and take it back to AF1 and let em hook up to it. Only I did yesterday was fill it up with non ethanol gas and that is when I notice fuel gauge was not showing full. Rode it bout 18 miles and shut it off far while it started back up fine rode it back home and pull over in shoulder on road to let a car pass and when I decelerated engine control light came on but it was running like usual all the way back to house. I thought about sucking gas out of tank and getting me some premium to put back in but I run non ethanol in Ural it is fuel injected no problem and run the NE in my mowers and other engines. O well trip back to Austin AF1. Not to much you can do with em without computer to hook them too.
@jet_peddler avatar
UTC

Veni, Vidi, Posti
'07 LX150 (Sold), '17 GTS300, '16 BV350, '15 EN650, '09 FXDF (sold). '15 FLSTN
Joined: UTC
Posts: 5664
Location: Home of the Alamo
 
Veni, Vidi, Posti
@jet_peddler avatar
'07 LX150 (Sold), '17 GTS300, '16 BV350, '15 EN650, '09 FXDF (sold). '15 FLSTN
Joined: UTC
Posts: 5664
Location: Home of the Alamo
UTC quote
Having the same ECL issue with my BV350, but with no noticeable issues associated with it. My light goes on for a day or two, then off for a month, then back on and so forth.
OP
@schultz avatar
UTC

Hooked
GTS 300
Joined: UTC
Posts: 109
Location: Cistern,Tx
 
Hooked
@schultz avatar
GTS 300
Joined: UTC
Posts: 109
Location: Cistern,Tx
UTC quote
This light is staying on and it ain't running to good. I would not trust it on the road. I was kinda looking it over in a hurry but where the hell is the evaporate cannister or what ever they put on them. I was trying to feel around the fuel tank but no luck.
UTC

Banned
2009 GTS 250, 2013 Buddy 125, 2014 Triumph Bonneville
Joined: UTC
Posts: 2038
Location: North Jersey
 
Banned
2009 GTS 250, 2013 Buddy 125, 2014 Triumph Bonneville
Joined: UTC
Posts: 2038
Location: North Jersey
UTC quote
I think you either overfilled the fuel or got a bad batch of gas.

Why not, as a first step before bringing it to a dealer and get charged mucho dinero, drain the gas out and re-fill with a major brand premium from a station that isn't in the middle of having a gas delivery?

But since you said "filled it up to the top" I think you may have overfilled it.
There are warning stickers on some, not all, models that state to not fill the gas so high that it sits in the filler neck. One symptom of overfilling is excessive vacuum pressure. This can be seen as when you unscrew the gas cap, you hear a WHOOSH!


*** NOTE TO JET PEDDLER---- You can also get excessive vacuum pressure just from riding in very hot environments. Since it's been 100 degrees in your area, this might be the cause of your intermittent engine light. The next time you see the light on a ride, pull over and stop and unscrew the gas cap and see if you get an unusually strong "WHOOSH".

On older scooters and motorcycles the gas caps were vented. But those California emissions requirements necessitated the introduction of the EVAP system where the gas caps are of course, no longer vented and the gas "fumes" are reintroduced to the carb or throttle body and are burned.
When you disconnect the EVAP system, you cut the hose that runs from the filler neck to the throttle body. You plug the end near the TB with a 7mm bolt and use a clamp around it. The other end, near the filler neck, you must extend with another piece of hose and run that to the bottom of the scooter, near the ground.

This thread, with pictures explains how to permanently disconnect the EVAP hose. It will suffice to show you where/what hose comes from your fuel filler neck. How to remove or disconnect the Evap Sys. from GTS/GTV
Forum member supplied image with no explanatory text
OP
@schultz avatar
UTC

Hooked
GTS 300
Joined: UTC
Posts: 109
Location: Cistern,Tx
 
Hooked
@schultz avatar
GTS 300
Joined: UTC
Posts: 109
Location: Cistern,Tx
UTC quote
To late took it back to AF1 and left it there so sometime next week should here from them. No sticker like that on this GTS. Don't think it is bad gas cause I keep some extra cans of non-ethanol around that I run in the Ural, zero turn mower, log splitter, mower, weed eater, chain saws well I run the NE in everything I got not cept the wifes Honda. When I took the dap off the tank there was never any pressure build up. It was running great rode it bout 18 miles to friends house stay there a while, it started up like normal then on way back home I noticed light on this was late in evening running normal came on and park it. Start up next day and it fires right up but was running ruff give it some throttle and it cuts back but never dies. I think it might have something to do with overfilling it but not sure. It I get charged for it so be it. Another lesson learned the hard way. I had a 2008 GTS and I was always careful about filling it up but I guess me fks up on dis one. And I imagine this one got more emission crap on it. See what they tell me next week.

Thinks for the link for removing the evap I was looking for something like this but me guess me miss it. Will do this when I get it back.
@jimc avatar
UTC

Moderaptor
The Hornet (GT200, aka Love Bug) and 'Dimples' - a GTS 300
Joined: UTC
Posts: 43737
Location: Pleasant Hill, CA
 
Moderaptor
@jimc avatar
The Hornet (GT200, aka Love Bug) and 'Dimples' - a GTS 300
Joined: UTC
Posts: 43737
Location: Pleasant Hill, CA
UTC quote
The CEL usually only comes on for two things - Lambda sensor out of whack or excessive voltage from the regulator. My bet given your symptoms is the Lambda sensor - either a broken wire (quite common) or a duff sensor (not so common).
OP
@schultz avatar
UTC

Hooked
GTS 300
Joined: UTC
Posts: 109
Location: Cistern,Tx
 
Hooked
@schultz avatar
GTS 300
Joined: UTC
Posts: 109
Location: Cistern,Tx
UTC quote
Ya I kinda leaning that way. Just my luck. But I will find out next week when they call me. I still think I might take that emission crap off. Motoguzzi has it on there bikes and I took it off the Stelvio I use to have.
@web-tech avatar
UTC

Veni, Vidi, Posti
2008 MP3 500, 2013 BV350, 2020 Vespa Sei Giorni, 2008 Vespa S150
Joined: UTC
Posts: 8951
Location: Ashburn, Va. Home to the Internet
 
Veni, Vidi, Posti
@web-tech avatar
2008 MP3 500, 2013 BV350, 2020 Vespa Sei Giorni, 2008 Vespa S150
Joined: UTC
Posts: 8951
Location: Ashburn, Va. Home to the Internet
UTC quote
schultz wrote:
Ya I kinda leaning that way. Just my luck. But I will find out next week when they call me. I still think I might take that emission crap off. Motoguzzi has it on there bikes and I took it off the Stelvio I use to have.
All you can remove is the Evap system, and that's not causing your light to come on.
DoubleGood Design banner

Modern Vespa is the premier site for modern Vespa and Piaggio scooters. Vespa GTS300, GTS250, GTV, GT200, LX150, LXS, ET4, ET2, MP3, Fuoco, Elettrica and more.

Buy Me A Coffee
 

Shop on Amazon with Modern Vespa

Modern Vespa is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com


All Content Copyright 2005-2024 by Modern Vespa.
All Rights Reserved.


[ Time: 0.0171s ][ Queries: 5 (0.0075s) ][ live ][ 313 ][ ThingOne ]