OP
@maxcielle avatar
UTC

Enthusiast
2000 ET2 50cc and 2003 ET4 150cc
Joined: UTC
Posts: 51
Location: ukb
 
Enthusiast
@maxcielle avatar
2000 ET2 50cc and 2003 ET4 150cc
Joined: UTC
Posts: 51
Location: ukb
UTC quote
Hi,

I was not having tale light, brake light and dashboard lights on my ET4 2003 150.

The turn lights and front light works nice.

I have substituted the rear bulb and I am back having brake light but still no rear light, and rear light it's mandatory to drive at night.

No dashboard lights also.

Can someone help?
@lord_ickenham avatar
UTC

Addicted
et 2 50cc
Joined: UTC
Posts: 828
Location: Hungary
 
Addicted
@lord_ickenham avatar
et 2 50cc
Joined: UTC
Posts: 828
Location: Hungary
UTC quote
I'd check and clean the connections.
OP
@maxcielle avatar
UTC

Enthusiast
2000 ET2 50cc and 2003 ET4 150cc
Joined: UTC
Posts: 51
Location: ukb
 
Enthusiast
@maxcielle avatar
2000 ET2 50cc and 2003 ET4 150cc
Joined: UTC
Posts: 51
Location: ukb
UTC quote
OK, will try.

It's really annoying because i can't drive at night like this.
UTC

Hooked
carnaby 125
Joined: UTC
Posts: 144
Location: uk
 
Hooked
carnaby 125
Joined: UTC
Posts: 144
Location: uk
UTC quote
maybe blown fuse

also if not then you must of got a wire that's come lose that powers the dash and rear bulb

if you not sure where the problem is and you don't want to pay mechanic to fix the wiring then find out which wire is the live for the rear light and cut it and link it to a live wire that actually works on the rear section


sometimes theres usually online manual book search will have colour is for what on the bulb section

Before you do cut try follow the live the 3 wires from the bulb section as the main live will be damaged somewhere and follow it to see if you can see a cut or where its not connected but if its to much hassle then do above of cutting wire and relink it

but as for the dash you would after trace the wire problem

found this with similar issue as you with wiring diagram might be same colours as yours ET4 125 Lights not working 100%

also does your numberplate light work
⬆️    About 2 months elapsed    ⬇️
OP
@maxcielle avatar
UTC

Enthusiast
2000 ET2 50cc and 2003 ET4 150cc
Joined: UTC
Posts: 51
Location: ukb
 
Enthusiast
@maxcielle avatar
2000 ET2 50cc and 2003 ET4 150cc
Joined: UTC
Posts: 51
Location: ukb
UTC quote
it got back working by it self. Then i just removed the battery and clean everything, no more worries. I think it was something with those connections in the area where the batteries seats.

thanks guys.
DoubleGood Design banner

Modern Vespa is the premier site for modern Vespa and Piaggio scooters. Vespa GTS300, GTS250, GTV, GT200, LX150, LXS, ET4, ET2, MP3, Fuoco, Elettrica and more.

Buy Me A Coffee
 

Shop on Amazon with Modern Vespa

Modern Vespa is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com


All Content Copyright 2005-2024 by Modern Vespa.
All Rights Reserved.


[ Time: 0.0182s ][ Queries: 4 (0.0074s) ][ live ][ 313 ][ ThingOne ]