OP
UTC

Member
GTS150
Joined: UTC
Posts: 6
Location: Thailand
 
Member
GTS150
Joined: UTC
Posts: 6
Location: Thailand
UTC quote
I have some problems with my GTS150 (Vietnam model) 2014. I have ridden it every day for 5 years but I have some issues with it. The engine starts pretty hard in the morning and I cannot hit the top speed if ride over 100kph (60mph) it starts jerky after that speed. I replace lots of things: v-belt, spark plug, spark cap & wire (NGK), Battery, air filter, variator&clucth service, O2 sensor, ECU. These changes cannot help it better. It still happens until today, so annoying.

If anyone faces with the same issues with me please kindly suggest for the solution. Thank you so much.
@orange_s150 avatar
UTC

Molto Verboso
S 190. Custom VNB 150
Joined: UTC
Posts: 1485
Location: CT
 
Molto Verboso
@orange_s150 avatar
S 190. Custom VNB 150
Joined: UTC
Posts: 1485
Location: CT
UTC quote
Need more information. What happens when you let off the throttle? Is it engine related? When is the last time belt and rollers were replaced?
@wheelman-111 avatar
UTC

Addicted
2010 S50 Modified "Punkin"; 2003 ET4 Malossi 187 "ISO"
Joined: UTC
Posts: 778
Location: Deepinnaharta, Texas
 
Addicted
@wheelman-111 avatar
2010 S50 Modified "Punkin"; 2003 ET4 Malossi 187 "ISO"
Joined: UTC
Posts: 778
Location: Deepinnaharta, Texas
UTC quote
Greetings:

Sounds like power cuts out repeatedly "Jerky?" at higher RPM. Multiple possible causes - RPM limiting device is my first thought if transmission rollers undersized or worn.
OP
UTC

Member
GTS150
Joined: UTC
Posts: 6
Location: Thailand
 
Member
GTS150
Joined: UTC
Posts: 6
Location: Thailand
UTC quote
orange s150 wrote:
Need more information. What happens when you let off the throttle? Is it engine related? When is the last time belt and rollers were replaced?
Thank you for your kind attention. When i release the throttle it's always brackfire. The belt was changed 3-4 times after it happens. The roller is fine.
OP
UTC

Member
GTS150
Joined: UTC
Posts: 6
Location: Thailand
 
Member
GTS150
Joined: UTC
Posts: 6
Location: Thailand
UTC quote
Wheelman-111 wrote:
Greetings:

Sounds like power cuts out repeatedly "Jerky?" at higher RPM. Multiple possible causes - RPM limiting device is my first thought if transmission rollers undersized or worn.
The belt is Polini i changed it last week. I think aomethink like that too because i install the power cable of NGK spark plug it may result high voltage of ignition. However, i found that the injector was not spray when i turn on the key. Is it abnormal or not?
@orange_s150 avatar
UTC

Molto Verboso
S 190. Custom VNB 150
Joined: UTC
Posts: 1485
Location: CT
 
Molto Verboso
@orange_s150 avatar
S 190. Custom VNB 150
Joined: UTC
Posts: 1485
Location: CT
UTC quote
I am not familiar with fuel injected systems. This is beyond what I can advise. If you have fuel injection you should have a check engine light. Is the light on?
@juan_orhea avatar
UTC

Molto Verboso
S150 '09, Beo 500ie '08
Joined: UTC
Posts: 1238
Location: Bermuda
 
Molto Verboso
@juan_orhea avatar
S150 '09, Beo 500ie '08
Joined: UTC
Posts: 1238
Location: Bermuda
UTC quote
Backfiring suggests a timing/valve problem. How many miles, and have the valves been adjusted? (Assuming this is a 4T engine.)
OP
UTC

Member
GTS150
Joined: UTC
Posts: 6
Location: Thailand
 
Member
GTS150
Joined: UTC
Posts: 6
Location: Thailand
UTC quote
orange s150 wrote:
I am not familiar with fuel injected systems. This is beyond what I can advise. If you have fuel injection you should have a check engine light. Is the light on?
There is no fault code or signal light appeared on the dashboard.
OP
UTC

Member
GTS150
Joined: UTC
Posts: 6
Location: Thailand
 
Member
GTS150
Joined: UTC
Posts: 6
Location: Thailand
UTC quote
Juan_ORhea wrote:
Backfiring suggests a timing/valve problem. How many miles, and have the valves been adjusted? (Assuming this is a 4T engine.)
The mileage is around 68,500km. I have been adjusted valves since 50,000km but this problem occurred before those miles. It doesn't help anything better.
I took the EFI cleaning yesterday but there is still having problem excepted a little bit easy start-up engine.
@tom_jones avatar
UTC

Hooked
Vespa GTS 150 3v SUPER. Vespa V100 x 1. Lambretta Li150 x 1. Px 125 x 2. Px 200 x 1 (red bull special) T5 Classic x 1. Vespa Cosa x 2.CF moto 650mt
Joined: UTC
Posts: 392
Location: Perth Australia
 
Hooked
@tom_jones avatar
Vespa GTS 150 3v SUPER. Vespa V100 x 1. Lambretta Li150 x 1. Px 125 x 2. Px 200 x 1 (red bull special) T5 Classic x 1. Vespa Cosa x 2.CF moto 650mt
Joined: UTC
Posts: 392
Location: Perth Australia
UTC quote
Juan_ORhea wrote:
Backfiring suggests a timing/valve problem. How many miles, and have the valves been adjusted? (Assuming this is a 4T engine.)
I concur. It's your valves. I have one of these scooters. Valves do require maintenance as per the recommended intervals.
@dooglas avatar
UTC

Veni, Vidi, Posti
GTS 300ABS, Buddy 125, Buddy Kick 125
Joined: UTC
Posts: 13378
Location: Oregon City, OR
 
Veni, Vidi, Posti
@dooglas avatar
GTS 300ABS, Buddy 125, Buddy Kick 125
Joined: UTC
Posts: 13378
Location: Oregon City, OR
UTC quote
orange s150 wrote:
I am not familiar with fuel injected systems.
Hmmm. Isn't the S 150 fuel injected?
@juan_orhea avatar
UTC

Molto Verboso
S150 '09, Beo 500ie '08
Joined: UTC
Posts: 1238
Location: Bermuda
 
Molto Verboso
@juan_orhea avatar
S150 '09, Beo 500ie '08
Joined: UTC
Posts: 1238
Location: Bermuda
UTC quote
The LX and S were carbureted up to about 2010. Apparently some of both in 2011, then FI from thenceforth.
DoubleGood Design banner

Modern Vespa is the premier site for modern Vespa and Piaggio scooters. Vespa GTS300, GTS250, GTV, GT200, LX150, LXS, ET4, ET2, MP3, Fuoco, Elettrica and more.

Buy Me A Coffee
 

Shop on Amazon with Modern Vespa

Modern Vespa is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com


All Content Copyright 2005-2024 by Modern Vespa.
All Rights Reserved.


[ Time: 0.0149s ][ Queries: 3 (0.0040s) ][ live ][ 313 ][ ThingOne ]