Notice
NOTICE!
Modern Vespa Private Message Changes

Changes to Modern Vespa's Private Message service are coming. Read about it here.


Sun Jul 04, 2021 6:11 pm

Member
paggio mp3
Joined: 03 Jul 2021
Posts: 5
Location: Australia
 
Member
paggio mp3
Joined: 03 Jul 2021
Posts: 5
Location: Australia
Sun Jul 04, 2021 6:11 pm linkquote
My tilt lock does not operate when ignition is turned on. It may take 10 or 20 attempts. When it does operate it is fine. Can some one give me a few hints. Battery is fully charged. Could it be a regulator.
Sun Jul 04, 2021 10:26 pm

Hooked
2015 MP3 500 ie Business
Joined: 29 Oct 2019
Posts: 424
Location: Belgium
 
Hooked
2015 MP3 500 ie Business
Joined: 29 Oct 2019
Posts: 424
Location: Belgium
Sun Jul 04, 2021 10:26 pm linkquote
Check fluid level first and foremost.

Does this happen every single time when you turn on the bike? And does the problem stay away until the next key cycle, like clockwork???
Sun Jul 04, 2021 11:52 pm

Member
paggio mp3
Joined: 03 Jul 2021
Posts: 5
Location: Australia
 
Member
paggio mp3
Joined: 03 Jul 2021
Posts: 5
Location: Australia
Sun Jul 04, 2021 11:52 pm linkquote
Fluid level is ok. I have done the fluid with a syringe. Bugger of a job.
No air in lines.
It happens all of the time. On off on off and so on. May be 20 times.
Might be ecu. But once it’s on its perfect.
Mon Jul 05, 2021 3:50 am

Hooked
2009 MP3 400, 2004 Honda ST1300
Joined: 11 Jun 2007
Posts: 359
Location: Sayre, PA
 
Hooked
2009 MP3 400, 2004 Honda ST1300
Joined: 11 Jun 2007
Posts: 359
Location: Sayre, PA
Mon Jul 05, 2021 3:50 am linkquote
Bad switch? They're not the greatest quality to begin with.

If you've got nimble fingers you may be ale to take it apart and clean it.
Mon Jul 05, 2021 5:05 am

Member
paggio mp3
Joined: 03 Jul 2021
Posts: 5
Location: Australia
 
Member
paggio mp3
Joined: 03 Jul 2021
Posts: 5
Location: Australia
Mon Jul 05, 2021 5:05 am linkquote
I would have already done the key but I didn’t think it would help as when I turn the key on everything else wwworks, lights and dash ect.
If you think it might help I’ll give it a go.
Tue Jul 06, 2021 2:34 am

Hooked
2009 MP3 400, 2004 Honda ST1300
Joined: 11 Jun 2007
Posts: 359
Location: Sayre, PA
 
Hooked
2009 MP3 400, 2004 Honda ST1300
Joined: 11 Jun 2007
Posts: 359
Location: Sayre, PA
Tue Jul 06, 2021 2:34 am linkquote
Not the key. Just the switch on the right side handlebar.
Mon Jul 19, 2021 2:54 pm

Hooked
Piaggio MP3 ie 400
Joined: 01 Jul 2017
Posts: 142
Location: Sydney
 
Hooked
Piaggio MP3 ie 400
Joined: 01 Jul 2017
Posts: 142
Location: Sydney
Mon Jul 19, 2021 2:54 pm linkquote
Brendanok wrote:
My tilt lock does not operate when ignition is turned on. It may take 10 or 20 attempts. When it does operate it is fine. Can some one give me a few hints. Battery is fully charged. Could it be a regulator.
Hi,
Depending on the age of the scooter, if it is old, and everything else is ok (battery etc...) and you done the maintenance, then most properly it will be the switch, you need to get the a new switch.
What you can do, if you have someone else who has a similar scooter is change the switch from their scooter to yours and check if it works, it is nearly a 45 minute work (from start to finish) and not hard,
Good luck.
  DoubleGood Vespa T-Shirts  

All Content Copyright 2005-2021 by Modern Vespa. All Rights Reserved.

Modern Vespa is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com.

Shop on Amazon Smile with Modern Vespa

[ Time: 0.0522s ][ Queries: 26 (0.0239s) ][ Debug on ][ 189 ][ Thing Two ]