OP
UTC

Hooked
vespa gts250
Joined: UTC
Posts: 246
Location: chicago
 
Hooked
vespa gts250
Joined: UTC
Posts: 246
Location: chicago
UTC quote
So yesterday after two 50 mile trips in one day the CEL has decided to come on and stay on, everything seems fine, runs ok, gonna check coolant level but it was on as soon as I start it while the engine was cold in the morning today too?

Anyone know what it could be? Bike has 3600 miles
@jess avatar
UTC

Petty Tyrant
0:7 And counting
Joined: UTC
Posts: 37339
Location: Bay Area, California
 
Petty Tyrant
@jess avatar
0:7 And counting
Joined: UTC
Posts: 37339
Location: Bay Area, California
UTC quote
It's not the coolant. I don't have any experience with the HPE, but historically, the biggest driver of the check engine light is the O2 sensor -- either disconnected or failing.
OP
UTC

Hooked
vespa gts250
Joined: UTC
Posts: 246
Location: chicago
 
Hooked
vespa gts250
Joined: UTC
Posts: 246
Location: chicago
UTC quote
jess wrote:
It's not the coolant. I don't have any experience with the HPE, but historically, the biggest driver of the check engine light is the O2 sensor -- either disconnected or failing.
So should I take it in or wait for it to go away? My old bike had lambda sensor reading issues all the time but it never did anything!
@jess avatar
UTC

Petty Tyrant
0:7 And counting
Joined: UTC
Posts: 37339
Location: Bay Area, California
 
Petty Tyrant
@jess avatar
0:7 And counting
Joined: UTC
Posts: 37339
Location: Bay Area, California
UTC quote
professorcatfacemeowmers wrote:
So should I take it in or wait for it to go away? My old bike had lambda sensor reading issues all the time but it never did anything!
I think it's worth taking in so they can read the actual fault code and diagnose the problem.
@retro_scoot avatar
UTC

Hooked
2020 GTS300 HPE "Whiskers"
Joined: UTC
Posts: 238
Location: Bama
 
Hooked
@retro_scoot avatar
2020 GTS300 HPE "Whiskers"
Joined: UTC
Posts: 238
Location: Bama
UTC quote
professorcatfacemeowmers wrote:
So yesterday after two 50 mile trips in one day the CEL has decided to come on and stay on, everything seems fine, runs ok, gonna check coolant level but it was on as soon as I start it while the engine was cold in the morning today too?

Anyone know what it could be? Bike has 3600 miles
If it came on soon after refueling, it's almost certainly the vapor recovery system/02 sensor. Mine has done it twice in some 3,500 miles. I spoke with my dealer and he said if it's running good and if the oil level was good and not over-full (BOTH of those oil-related things he stressed) then just ride it and it should go out on its own. In both cases my light went out by the next day of riding. I did crack the gas cap in both instances to vent the pressure (then retightened) FWIW and took more care from then on when refueling so as not to slop any fuel down the drain hole or try to fill it to the brim. (I'd been a little sloppy in the past) Just another quirk in my book but nothing to fuss about.

Bike runs like a champ with zero issues. I don't worry about it. Hope that puts your mind at ease.
OP
UTC

Hooked
vespa gts250
Joined: UTC
Posts: 246
Location: chicago
 
Hooked
vespa gts250
Joined: UTC
Posts: 246
Location: chicago
UTC quote
Retro Scoot wrote:
If it came on soon after refueling, it's almost certainly the vapor recovery system/02 sensor. Mine has done it twice in some 3,500 miles. I spoke with my dealer and he said if it's running good and if the oil level was good and not over-full (BOTH of those oil-related things he stressed) then just ride it and it should go out on its own. In both cases my light went out by the next day of riding. I did crack the gas cap in both instances to vent the pressure (then retightened) FWIW and took more care from then on when refueling so as not to slop any fuel down the drain hole or try to fill it to the brim. (I'd been a little sloppy in the past) Just another quirk in my book but nothing to fuss about.

Bike runs like a champ with zero issues. I don't worry about it. Hope that puts your mind at ease.
This happened like 15 minutes after refilling, it's still there today but I think it'll go away as I burn gas! Same here nothing is running different!
DoubleGood Design banner

Modern Vespa is the premier site for modern Vespa and Piaggio scooters. Vespa GTS300, GTS250, GTV, GT200, LX150, LXS, ET4, ET2, MP3, Fuoco, Elettrica and more.

Buy Me A Coffee
 

Shop on Amazon with Modern Vespa

Modern Vespa is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com


All Content Copyright 2005-2024 by Modern Vespa.
All Rights Reserved.


[ Time: 0.0104s ][ Queries: 3 (0.0026s) ][ live ][ 313 ][ ThingOne ]