OP
@adri avatar
UTC

Atypical Canadian
2009 Vespa S50(LX150 motor swap), 2006 Vespa GTS250ie
Joined: UTC
Posts: 2318
Location: Toronto, Canada
 
Atypical Canadian
@adri avatar
2009 Vespa S50(LX150 motor swap), 2006 Vespa GTS250ie
Joined: UTC
Posts: 2318
Location: Toronto, Canada
UTC quote
Trying to help someone with a Vespa LX150 with a total no start issue. Doesn't even crank, no headlight, nothing, totally dead. I don't even have a dashboard red LED light flashing for the security system. Battery is charged, holding, tight, and correct.

I've been looking for fuses and only found 2 beside the battery, and 2 behind the horn cover, for a total of four fuses. I believe they were all 15 amp (I'd have to go back and check). All looked to be okay but I didn't take a multimeter in there.

Am I missing something? Is there a "main fuse" hiding somewhere else? TY!
@znomit avatar
UTC

Veni, Vidi, Posti
LX190 Friday afternoon special, Primavera, S50, too many pushbikes
Joined: UTC
Posts: 10259
Location: Hermit Kingdom
 
Veni, Vidi, Posti
@znomit avatar
LX190 Friday afternoon special, Primavera, S50, too many pushbikes
Joined: UTC
Posts: 10259
Location: Hermit Kingdom
UTC quote
Check fuses with a meter. They sometimes look OK but aren't.
DoubleGood Design banner

Modern Vespa is the premier site for modern Vespa and Piaggio scooters. Vespa GTS300, GTS250, GTV, GT200, LX150, LXS, ET4, ET2, MP3, Fuoco, Elettrica and more.

Buy Me A Coffee
 

Shop on Amazon with Modern Vespa

Modern Vespa is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com


All Content Copyright 2005-2024 by Modern Vespa.
All Rights Reserved.


[ Time: 0.0076s ][ Queries: 3 (0.0020s) ][ live ][ 313 ][ ThingOne ]