Tue, 18 Oct 2022 18:01:29 +0000

Addicted
2003 Piaggio BV 200, 2003 ET2 (sold)
Joined: Fri, 09 Oct 2009 06:21:17 +0000
Posts: 593
Location: Salt Lake City, Utah
 
Addicted
2003 Piaggio BV 200, 2003 ET2 (sold)
Joined: Fri, 09 Oct 2009 06:21:17 +0000
Posts: 593
Location: Salt Lake City, Utah
Tue, 18 Oct 2022 18:01:29 +0000 quote
I'm still thinking about that A/F screw, and how having it all the way in didn't actually stop the scoot from running. That seems like a weird enough issue that it's worth really focusing on. So, since for your carbs the A/F screw when turned all the way in means no more AIR, right? So yeah, seems like air is getting in anyway. If you can determine how the air's getting in, maybe that will solve the problem?

I did some googling and found a few forums where someone had a similar issue—obviously these are different vehicles so grain of salt, etc.

Also, can you confirm that you have all the little fiddly bits installed correctly? E.g. tiny o-rings?


https://www.advrider.com/f/threads/engine-still-runs-even-when-mixture-screw-is-turned-all-the-way-in.1048552/

https://www.advrider.com/f/threads/mixture-screw-all-the-way-in.226651/

https://scootdawg.proboards.com/thread/28012/air-mixture-screw-effect-solved

https://www.vmaxforum.net/threads/unresponsive-a-f-mixture-adjustments.20915/
OP
Wed, 19 Oct 2022 00:13:02 +0000

Member
ET4
Joined: Thu, 11 Aug 2022 01:04:04 +0000
Posts: 40
Location: Texas
 
OP
Member
ET4
Joined: Thu, 11 Aug 2022 01:04:04 +0000
Posts: 40
Location: Texas
Wed, 19 Oct 2022 00:13:02 +0000 quote
greasy125 wrote:
I'm not a fan of that air filter, I'd install a stock one and see if the problem persists.

you say that the exhaust got red hot just idling? how long was it idling?
Sitting idle it's fine. Wide open throttle it gets red.

I'll pick up a stock filter. I have some bigger jets on the way as well.
OP
Sat, 29 Oct 2022 13:23:11 +0000

Member
ET4
Joined: Thu, 11 Aug 2022 01:04:04 +0000
Posts: 40
Location: Texas
 
OP
Member
ET4
Joined: Thu, 11 Aug 2022 01:04:04 +0000
Posts: 40
Location: Texas
Sat, 29 Oct 2022 13:23:11 +0000 quote
A couple updates.

I put in a bigger main. Agent from stock 82 to a 85. Made it worse.

Put in a stock air filter. Helped a bunch. Acceleration much better but the to end is still only 30-35 mph. The air screw is still all the way in. If you back it out a half a turn, you can hear the engine drop. Feels like it's still too much air.

Feels like progress.

Thoughts.
⬆️    About 4w elapsed between posts    ⬇️
Mon, 28 Nov 2022 20:03:21 +0000

Member
Vespa et4 leadier 125, Vespa Lx 50 2t
Joined: Sat, 12 Nov 2022 21:16:34 +0000
Posts: 15
Location: Vilnius
 
Member
Vespa et4 leadier 125, Vespa Lx 50 2t
Joined: Sat, 12 Nov 2022 21:16:34 +0000
Posts: 15
Location: Vilnius
Mon, 28 Nov 2022 20:03:21 +0000 quote
I see that the carburetor vacuum valve (or, the slide, in other words) is scratched and I don't know whether Keihn has a special coating on it, which might be worn off in this case, and the slide maybe not move freely. My Walbro Wvf Japan has some teflon-like layer that is blown off partially. I wonder, can I still use the valve or shall I replace it?[img][/img]



  DoubleGood Design  

Modern Vespa is the premier site for modern Vespa and Piaggio scooters. Vespa GTS300, GTS250, GTV, GT200, LX150, LXS, ET4, ET2, MP3, Fuoco, Elettrica and more.


Shop on Amazon with Modern Vespa

Modern Vespa is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com

All Content Copyright 2005-2023 by Modern Vespa. All Rights Reserved.

[ Time: 0.0287s ][ Queries: 6 (0.0067s) ][ Debug on ][ 276 ][ Thing Two ]