Member
Piaggio MP3 500
Joined: 17 Feb 2012
Posts: 15
Location: philadelphia, pa
 
Member
Piaggio MP3 500
Joined: 17 Feb 2012
Posts: 15
Location: philadelphia, pa
I have a 2010 MP3 500 that has experienced the familiar tilt-lock 5 beep warning periodically.

My dealer diagnosed the tilt-lock issue to be the tilt-lock pressure sensor, part number 640295. They replaced the hydraulic fluid in the system but didn't have the part in stock.

Trouble is that the dealer (Eurosports in Coopersburg, PA) is a 3 hour round trip for me, so I thought I could replace the part myself.

Is it just a matter of unscrewing the part and screwing in a new one? Will I have to re-flush the hydraulic fluid? Reset something on the ECU to make it all work?

I hear that this is a very common problem, but I've never seen any thread about the steps to replace the sensor.

Help appreciated.

Thanks!


Piaggio Pressure Sensor (640295)


Veni, Vidi, Posti
MP3 500, GTS 250 (both 2008 MY), 2013 Piaggio BV 350, 2014 Can Am Spyder RT
Joined: 02 Mar 2013
Posts: 7126
Location: Madison, Wisconsin
 
Veni, Vidi, Posti
MP3 500, GTS 250 (both 2008 MY), 2013 Piaggio BV 350, 2014 Can Am Spyder RT
Joined: 02 Mar 2013
Posts: 7126
Location: Madison, Wisconsin
It's not too difficult, but there are a few steps.

Remove the front end plastics.
Drain out the tilt lock fluid so the sensor is above fluid level. Otherwise you'll just spill it.
Remove old sensor.
Install new sensor (be sure you replace all the little washers; I think there were two of them when I did my pressure switch a couple months ago).
Pressure bleed from the bottom to fill the system. This will push any air between the pressure switch and the pump out. IF you only drained it as much as really required....
Replace front end plastics.

Hooked
Piaggio MP3 500LT
Joined: 20 Mar 2014
Posts: 189
Location: South Wales
 
Hooked
Piaggio MP3 500LT
Joined: 20 Mar 2014
Posts: 189
Location: South Wales
If I remember correctly bleeding should be on the stand with tilt lock disengaged.

Veni, Vidi, Posti
MP3 500, GTS 250 (both 2008 MY), 2013 Piaggio BV 350, 2014 Can Am Spyder RT
Joined: 02 Mar 2013
Posts: 7126
Location: Madison, Wisconsin
 
Veni, Vidi, Posti
MP3 500, GTS 250 (both 2008 MY), 2013 Piaggio BV 350, 2014 Can Am Spyder RT
Joined: 02 Mar 2013
Posts: 7126
Location: Madison, Wisconsin
prof1967 wrote:
If I remember correctly bleeding should be on the stand with tilt lock disengaged.
Good point; correct.

Member
Piaggio MP3 500
Joined: 17 Feb 2012
Posts: 15
Location: philadelphia, pa
 
Member
Piaggio MP3 500
Joined: 17 Feb 2012
Posts: 15
Location: philadelphia, pa
Thanks for the concise summary. So, I shouldn't have to worry about any ECU resets or the like.

I know the system was just filled with new fluid, so having not done this before, could I just:

1) attach a lenght of plastic tube and large syringe to the bleed connector
2) suck out fluid as I loosen the sensor until it the fluid drops below the sensor level
3) replace with new sensor
4) push on syringe until air is expelled and a bit of fluid comes out at the sensor
5) tighten the sensor

Am I too naive?

Veni, Vidi, Posti
MP3 500, GTS 250 (both 2008 MY), 2013 Piaggio BV 350, 2014 Can Am Spyder RT
Joined: 02 Mar 2013
Posts: 7126
Location: Madison, Wisconsin
 
Veni, Vidi, Posti
MP3 500, GTS 250 (both 2008 MY), 2013 Piaggio BV 350, 2014 Can Am Spyder RT
Joined: 02 Mar 2013
Posts: 7126
Location: Madison, Wisconsin
rodbrent wrote:
Thanks for the concise summary. So, I shouldn't have to worry about any ECU resets or the like.

I know the system was just filled with new fluid, so having not done this before, could I just:

1) attach a lenght of plastic tube and large syringe to the bleed connector
2) suck out fluid as I loosen the sensor until it the fluid drops below the sensor level
3) replace with new sensor
4) push on syringe until air is expelled and a bit of fluid comes out at the sensor
5) tighten the sensor

Am I too naive?
I have a personal dislike for reusing any fluid I remove from a vehicle.
Also, it would be more difficult, I think, to avoid air bubbles.
Oh, and you need to bleed after installing the new sensor (tight); you have to push fluid all the way up and into the reservoir otherwise there WILL be air in it.

Veni, Vidi, Posti
Neutrino MP3 492.7 AK, 2013 Moto Guzzi Norge
Joined: 29 Mar 2008
Posts: 22126
Location: Harriman, Tennessee, Tn
 
Veni, Vidi, Posti
Neutrino MP3 492.7 AK, 2013 Moto Guzzi Norge
Joined: 29 Mar 2008
Posts: 22126
Location: Harriman, Tennessee, Tn
rodbrent wrote:
Thanks for the concise summary. So, I shouldn't have to worry about any ECU resets or the like.

I know the system was just filled with new fluid, so having not done this before, could I just:

1) attach a lenght of plastic tube and large syringe to the bleed connector
2) suck out fluid as I loosen the sensor until it the fluid drops below the sensor level
3) replace with new sensor
4) push on syringe until air is expelled and a bit of fluid comes out at the sensor
5) tighten the sensor

Am I too naive?
fluid is cheap, just replace.

Veni, Vidi, Posti
MP3 500, GTS 250 (both 2008 MY), 2013 Piaggio BV 350, 2014 Can Am Spyder RT
Joined: 02 Mar 2013
Posts: 7126
Location: Madison, Wisconsin
 
Veni, Vidi, Posti
MP3 500, GTS 250 (both 2008 MY), 2013 Piaggio BV 350, 2014 Can Am Spyder RT
Joined: 02 Mar 2013
Posts: 7126
Location: Madison, Wisconsin
old as dirt wrote:
rodbrent wrote:
Thanks for the concise summary. So, I shouldn't have to worry about any ECU resets or the like.

I know the system was just filled with new fluid, so having not done this before, could I just:

1) attach a lenght of plastic tube and large syringe to the bleed connector
2) suck out fluid as I loosen the sensor until it the fluid drops below the sensor level
3) replace with new sensor
4) push on syringe until air is expelled and a bit of fluid comes out at the sensor
5) tighten the sensor

Am I too naive?
fluid is cheap, just replace.
That's a good point too.
$100 sensor.
$4 DOT4 brake fluid.

Veni, Vidi, Posti
Neutrino MP3 492.7 AK, 2013 Moto Guzzi Norge
Joined: 29 Mar 2008
Posts: 22126
Location: Harriman, Tennessee, Tn
 
Veni, Vidi, Posti
Neutrino MP3 492.7 AK, 2013 Moto Guzzi Norge
Joined: 29 Mar 2008
Posts: 22126
Location: Harriman, Tennessee, Tn
Madison Sully wrote:
old as dirt wrote:
rodbrent wrote:
Thanks for the concise summary. So, I shouldn't have to worry about any ECU resets or the like.

I know the system was just filled with new fluid, so having not done this before, could I just:

1) attach a lenght of plastic tube and large syringe to the bleed connector
2) suck out fluid as I loosen the sensor until it the fluid drops below the sensor level
3) replace with new sensor
4) push on syringe until air is expelled and a bit of fluid comes out at the sensor
5) tighten the sensor

Am I too naive?
fluid is cheap, just replace.
That's a good point too.
$100 sensor.
$4 DOT4 brake fluid.
just like saving .02 Cents on a gallon of gas from the cheap station that I would not even use in my lawn mower but folks still go out of their way to save that .02 cents versus getting a top tier gas.
⬆️    About 36w elapsed between posts    ⬇️

Member
Piaggio MP3 500
Joined: 17 Feb 2012
Posts: 15
Location: philadelphia, pa
 
Member
Piaggio MP3 500
Joined: 17 Feb 2012
Posts: 15
Location: philadelphia, pa
Madison Sully wrote:
It's not too difficult, but there are a few steps.

Remove the front end plastics.
Drain out the tilt lock fluid so the sensor is above fluid level. Otherwise you'll just spill it.
Remove old sensor.
Install new sensor (be sure you replace all the little washers; I think there were two of them when I did my pressure switch a couple months ago).
Pressure bleed from the bottom to fill the system. This will push any air between the pressure switch and the pump out. IF you only drained it as much as really required....
Replace front end plastics.
Madison, where do you drain and fill the fluid? I couldn't find any reference to that service in the shop manual.

Veni, Vidi, Posti
MP3 500, GTS 250 (both 2008 MY), 2013 Piaggio BV 350, 2014 Can Am Spyder RT
Joined: 02 Mar 2013
Posts: 7126
Location: Madison, Wisconsin
 
Veni, Vidi, Posti
MP3 500, GTS 250 (both 2008 MY), 2013 Piaggio BV 350, 2014 Can Am Spyder RT
Joined: 02 Mar 2013
Posts: 7126
Location: Madison, Wisconsin
rodbrent wrote:
Madison Sully wrote:
It's not too difficult, but there are a few steps.

Remove the front end plastics.
Drain out the tilt lock fluid so the sensor is above fluid level. Otherwise you'll just spill it.
Remove old sensor.
Install new sensor (be sure you replace all the little washers; I think there were two of them when I did my pressure switch a couple months ago).
Pressure bleed from the bottom to fill the system. This will push any air between the pressure switch and the pump out. IF you only drained it as much as really required....
Replace front end plastics.
Madison, where do you drain and fill the fluid? I couldn't find any reference to that service in the shop manual.
Filling to top up is that container up top with the black screw-on lid. To bleed, there are bleed screws located just above and inside the wheels. I'll go get a picture and parts list link shortly....

Veni, Vidi, Posti
MP3 500, GTS 250 (both 2008 MY), 2013 Piaggio BV 350, 2014 Can Am Spyder RT
Joined: 02 Mar 2013
Posts: 7126
Location: Madison, Wisconsin
 
Veni, Vidi, Posti
MP3 500, GTS 250 (both 2008 MY), 2013 Piaggio BV 350, 2014 Can Am Spyder RT
Joined: 02 Mar 2013
Posts: 7126
Location: Madison, Wisconsin
Here is the location of the tilt lock bleed screws, and a parts list exploded drawing.


Not so close up.


Close up. The black rubber cap is off the bleed screw.


And the exploded view of the parts.


Member
Piaggio MP3 500
Joined: 17 Feb 2012
Posts: 15
Location: philadelphia, pa
 
Member
Piaggio MP3 500
Joined: 17 Feb 2012
Posts: 15
Location: philadelphia, pa
Madison Sully wrote:
Here is the location of the tilt lock bleed screws, and a parts list exploded drawing.
Wonderful. Thanks for the pics. I suppose it is the same on the 500.

Member
Piaggio MP3 500
Joined: 17 Feb 2012
Posts: 15
Location: philadelphia, pa
 
Member
Piaggio MP3 500
Joined: 17 Feb 2012
Posts: 15
Location: philadelphia, pa
Madison Sully wrote:
It's not too difficult, but there are a few steps.
...
Install new sensor (be sure you replace all the little washers; I think there were two of them when I did my pressure switch a couple months ago). ...
I'm up to this step and I want to do it ONCE, correctly.

I have the two washers, but I'm not sure if they were BOTH on the sensor side or one there and one on the other side of the hydraulic junction - which seems logical. However, it may have been the former, i.e., both washers together on the sensor side.

Do you remember?

Member
Piaggio MP3 500
Joined: 17 Feb 2012
Posts: 15
Location: philadelphia, pa
 
Member
Piaggio MP3 500
Joined: 17 Feb 2012
Posts: 15
Location: philadelphia, pa
Madison Sully wrote:
Oh, and you need to bleed after installing the new sensor (tight); you have to push fluid all the way up and into the reservoir otherwise there WILL be air in it.
One more detail: do you have to "exercise" the tilt-lock in the midst of pushing new fluid up into the reservoir to make sure bubbles are out of all parts of the hydraulics before or after you fully tighten the sensor?

Veni, Vidi, Posti
MP3 500, GTS 250 (both 2008 MY), 2013 Piaggio BV 350, 2014 Can Am Spyder RT
Joined: 02 Mar 2013
Posts: 7126
Location: Madison, Wisconsin
 
Veni, Vidi, Posti
MP3 500, GTS 250 (both 2008 MY), 2013 Piaggio BV 350, 2014 Can Am Spyder RT
Joined: 02 Mar 2013
Posts: 7126
Location: Madison, Wisconsin
rodbrent wrote:
Madison Sully wrote:
It's not too difficult, but there are a few steps.
...
Install new sensor (be sure you replace all the little washers; I think there were two of them when I did my pressure switch a couple months ago). ...
I'm up to this step and I want to do it ONCE, correctly.

I have the two washers, but I'm not sure if they were BOTH on the sensor side or one there and one on the other side of the hydraulic junction - which seems logical. However, it may have been the former, i.e., both washers together on the sensor side.

Do you remember?
One washer on each side of the hydraulic hose.

Veni, Vidi, Posti
MP3 500, GTS 250 (both 2008 MY), 2013 Piaggio BV 350, 2014 Can Am Spyder RT
Joined: 02 Mar 2013
Posts: 7126
Location: Madison, Wisconsin
 
Veni, Vidi, Posti
MP3 500, GTS 250 (both 2008 MY), 2013 Piaggio BV 350, 2014 Can Am Spyder RT
Joined: 02 Mar 2013
Posts: 7126
Location: Madison, Wisconsin
rodbrent wrote:
Madison Sully wrote:
Oh, and you need to bleed after installing the new sensor (tight); you have to push fluid all the way up and into the reservoir otherwise there WILL be air in it.
One more detail: do you have to "exercise" the tilt-lock in the midst of pushing new fluid up into the reservoir to make sure bubbles are out of all parts of the hydraulics before or after you fully tighten the sensor?
Fully install the new sensor, then push bleed from the bottom to fill.
I did not exercise the tilt lock until after the system was full, and that was just to confirm function. If there is air in the system downstream of the pump, you'll get the horn....

Member
Piaggio MP3 500
Joined: 17 Feb 2012
Posts: 15
Location: philadelphia, pa
 
Member
Piaggio MP3 500
Joined: 17 Feb 2012
Posts: 15
Location: philadelphia, pa
Madison Sully wrote:
rodbrent wrote:
Madison Sully wrote:
Oh, and you need to bleed after installing the new sensor (tight); you have to push fluid all the way up and into the reservoir otherwise there WILL be air in it.
One more detail: do you have to "exercise" the tilt-lock in the midst of pushing new fluid up into the reservoir to make sure bubbles are out of all parts of the hydraulics before or after you fully tighten the sensor?
Fully install the new sensor, then push bleed from the bottom to fill.
I did not exercise the tilt lock until after the system was full, and that was just to confirm function. If there is air in the system downstream of the pump, you'll get the horn....
Success!! I can't thank you enough for your help. Gave me the confidence to tackle this kind of job for the first time. I could see some fluid in the connector housing of the old switch - clearly that was at fault.

No beeps after the new switch was installed. Gave it a test ride turning the tilt-lock on/off several times. I'll park it on the stand with tilt-lock off from now on.

Thanks,
Rod

Veni, Vidi, Posti
MP3 500, GTS 250 (both 2008 MY), 2013 Piaggio BV 350, 2014 Can Am Spyder RT
Joined: 02 Mar 2013
Posts: 7126
Location: Madison, Wisconsin
 
Veni, Vidi, Posti
MP3 500, GTS 250 (both 2008 MY), 2013 Piaggio BV 350, 2014 Can Am Spyder RT
Joined: 02 Mar 2013
Posts: 7126
Location: Madison, Wisconsin
rodbrent wrote:
Madison Sully wrote:
rodbrent wrote:
Madison Sully wrote:
Oh, and you need to bleed after installing the new sensor (tight); you have to push fluid all the way up and into the reservoir otherwise there WILL be air in it.
One more detail: do you have to "exercise" the tilt-lock in the midst of pushing new fluid up into the reservoir to make sure bubbles are out of all parts of the hydraulics before or after you fully tighten the sensor?
Fully install the new sensor, then push bleed from the bottom to fill.
I did not exercise the tilt lock until after the system was full, and that was just to confirm function. If there is air in the system downstream of the pump, you'll get the horn....
Success!! I can't thank you enough for your help. Gave me the confidence to tackle this kind of job for the first time. I could see some fluid in the connector housing of the old switch - clearly that was at fault.

No beeps after the new switch was installed. Gave it a test ride turning the tilt-lock on/off several times. I'll park it on the stand with tilt-lock off from now on.

Thanks,
Rod
Bravo! Glad it worked out.
And yes, that brake fluid in the connector is a give-away, you found the problem.

Cheers!
⬆️    About 4y elapsed between posts    ⬇️

Member
2008 MP3 500
Joined: 25 Apr 2020
Posts: 16
Location: NorCal
 
Member
2008 MP3 500
Joined: 25 Apr 2020
Posts: 16
Location: NorCal
Pro tip: don't overtorque it.....


Over tightened


Veni, Vidi, Posti
MP3 500, GTS 250 (both 2008 MY), 2013 Piaggio BV 350, 2014 Can Am Spyder RT
Joined: 02 Mar 2013
Posts: 7126
Location: Madison, Wisconsin
 
Veni, Vidi, Posti
MP3 500, GTS 250 (both 2008 MY), 2013 Piaggio BV 350, 2014 Can Am Spyder RT
Joined: 02 Mar 2013
Posts: 7126
Location: Madison, Wisconsin
ClassicRocker3D wrote:
Pro tip: don't overtorque it.....

Ouch.

Sorta surprised to see you got the front end out; good work there at least.
   

All Content Copyright 2005-2022 by Modern Vespa. All Rights Reserved.

Modern Vespa is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com.

Shop on Amazon Smile with Modern Vespa

[ Time: 0.0358s ][ Queries: 7 (0.0100s) ][ Debug on ][ 233 ][ Thing One ]