Tue, 18 Oct 2022 18:19:23 +0000

Lurker
piaggio MP3 500
Joined: Tue, 18 Oct 2022 18:08:33 +0000
Posts: 2
Location: belgium
 
Lurker
piaggio MP3 500
Joined: Tue, 18 Oct 2022 18:08:33 +0000
Posts: 2
Location: belgium
Tue, 18 Oct 2022 18:19:23 +0000 linkquote
Hello,
I have a Piaggio MP3 500. During a ride I get a warning light "oil" and my engine stalls. After a stop I check the oil, it is nicely level. I start the engine back and it "runs" nicely for 15 seconds later a "screeching" sound coming up...back at home I check the engine. I take out the complete vario and start the engine again, again a high-pitched screeching sound from the inside of the engine. Waited a while, tried again. The first 15 sec everything is ok, then an emerging screeching sound. Nafenoeg the oil lamp continues to burn. There is enough oil in the motor. Anyone have an idea what this could be?
Tue, 18 Oct 2022 20:38:17 +0000

Member
2007 MP3 250ie / 2022 MP3 500HPE SA
Joined: Fri, 03 Jun 2022 22:01:48 +0000
Posts: 48
Location: CCS-Vzla
 
Member
2007 MP3 250ie / 2022 MP3 500HPE SA
Joined: Fri, 03 Jun 2022 22:01:48 +0000
Posts: 48
Location: CCS-Vzla
Tue, 18 Oct 2022 20:38:17 +0000 linkquote
For me sounds as you oil pump is broken or something similar.
Tue, 18 Oct 2022 21:22:41 +0000

Veni, Vidi, Posti
Neutrino MP3 492.7 AK, 2013 Moto Guzzi Norge
Joined: Sun, 30 Mar 2008 04:38:24 +0000
Posts: 22126
Location: Harriman, Tennessee, Tn
 
Veni, Vidi, Posti
Neutrino MP3 492.7 AK, 2013 Moto Guzzi Norge
Joined: Sun, 30 Mar 2008 04:38:24 +0000
Posts: 22126
Location: Harriman, Tennessee, Tn
Tue, 18 Oct 2022 21:22:41 +0000 linkquote
yup sounds like an oil pump failure and your seizing the motor.
Tue, 18 Oct 2022 22:25:05 +0000

Molto Verboso
2006 LX150 (carbed) | 2007 GT200
Joined: Wed, 29 Jun 2016 14:22:10 +0000
Posts: 1733
Location: Toronto
 
Molto Verboso
2006 LX150 (carbed) | 2007 GT200
Joined: Wed, 29 Jun 2016 14:22:10 +0000
Posts: 1733
Location: Toronto
Tue, 18 Oct 2022 22:25:05 +0000 linkquote
Qbek wrote:
the oil lamp continues to burn. There is enough oil in the motor. Anyone have an idea what this could be?
To clarify, the oil sensor measures oil pressure not oil level. The engine may have enough oil, but still have a serious oil-related problem. This is why others are saying your oil pump may have failed to cause this.
Wed, 19 Oct 2022 14:23:22 +0000

Lurker
piaggio MP3 500
Joined: Tue, 18 Oct 2022 18:08:33 +0000
Posts: 2
Location: belgium
 
Lurker
piaggio MP3 500
Joined: Tue, 18 Oct 2022 18:08:33 +0000
Posts: 2
Location: belgium
Wed, 19 Oct 2022 14:23:22 +0000 linkquote
the oil pump,whats the best way to replace?
Wed, 19 Oct 2022 15:03:31 +0000

Ossessionato
1979 P150X, 1983 P200E, 1988 T5, 1995 PX200E, 2011 Yamaha Fazer 600 S2
Joined: Sun, 02 Aug 2015 18:39:51 +0000
Posts: 3351
Location: Veria, Greece
 
Ossessionato
1979 P150X, 1983 P200E, 1988 T5, 1995 PX200E, 2011 Yamaha Fazer 600 S2
Joined: Sun, 02 Aug 2015 18:39:51 +0000
Posts: 3351
Location: Veria, Greece
Wed, 19 Oct 2022 15:03:31 +0000 linkquote
Pretty typical, they were prone to teeth failure. You need to split the engine to replace the oil pump...



Wed, 19 Oct 2022 20:43:49 +0000

Addicted
2015 MP3 500 ie Business
Joined: Tue, 29 Oct 2019 17:22:26 +0000
Posts: 911
Location: Belgium
 
Addicted
2015 MP3 500 ie Business
Joined: Tue, 29 Oct 2019 17:22:26 +0000
Posts: 911
Location: Belgium
Wed, 19 Oct 2022 20:43:49 +0000 linkquote
Whatever you do, do NOT start or drive the engine any further.

Without oil pressure, the engine will self destruct and perhaps already has started to.

As was mentioned, it is a engine out and complete teardown job. Be sure to check the cylinder bore and crank for signs of damage from oil starvation (scoring, etc.)
   

All Content Copyright 2005-2022 by Modern Vespa. All Rights Reserved.

Modern Vespa is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com.

Shop on Amazon Smile with Modern Vespa

[ Time: 0.0269s ][ Queries: 6 (0.0070s) ][ Debug on ][ 240 ][ Thing Two ]