OP
@baboon99 avatar
UTC

Enthusiast
Piaggio MP3 300ie
Joined: UTC
Posts: 54
Location: South Shields
 
Enthusiast
@baboon99 avatar
Piaggio MP3 300ie
Joined: UTC
Posts: 54
Location: South Shields
UTC quote
So for a while now I have this weird noise coming from the left hand side when driving.
Thought is was just coming from the air filter as changed it for a malossi one.

Only seem to get the noise after about 400 yrds of driving.

Then today I was driving and my oil light came on and then went off, and only was coming on when I throttle up.

So my thoughts are now could it be the oil pump or connector.

Bit history on the mp3 40k miles done, replaced a few thing and recently the sprag clutch, and me thinking the oil light issue might be the connector as I have to disconnect to get at sprag.

How easy is the oil pump replacement.
OP
@baboon99 avatar
UTC

Enthusiast
Piaggio MP3 300ie
Joined: UTC
Posts: 54
Location: South Shields
 
Enthusiast
@baboon99 avatar
Piaggio MP3 300ie
Joined: UTC
Posts: 54
Location: South Shields
UTC quote
Just an update checked the pressure swith connection and found oil inside. Oil had filled up the cap weird.
So cleaned it up and drove a few miles checked again and more oil in cap.
So new pressure sensor ordered.
@safis avatar
UTC

Ossessionato
1979 P150X, 1983 P200E, 1987 PK125XL Elestart, 1988 T5, 1995 PX200E, 2011 Yamaha Fazer 600 S2
Joined: UTC
Posts: 4158
Location: Veria, Greece
 
Ossessionato
@safis avatar
1979 P150X, 1983 P200E, 1987 PK125XL Elestart, 1988 T5, 1995 PX200E, 2011 Yamaha Fazer 600 S2
Joined: UTC
Posts: 4158
Location: Veria, Greece
UTC quote
What is the pressure switch connection?? Do you mean the oil pressure sensor like in the first photo?? It should have oil inside. Pressurized oil goes in, oil pressure warning light goes off. If light goes on while riding, your pump might be failing. They're prone to teeth breaking...

Oil pump replacement means whole engine split...
Forum member supplied image with no explanatory text
Forum member supplied image with no explanatory text
OP
@baboon99 avatar
UTC

Enthusiast
Piaggio MP3 300ie
Joined: UTC
Posts: 54
Location: South Shields
 
Enthusiast
@baboon99 avatar
Piaggio MP3 300ie
Joined: UTC
Posts: 54
Location: South Shields
UTC quote
Mine is a 300 yourban
The oil is in the rubber cover for the spade connector as not even pull the sensor out.
My oil pump can be done from the variator side
@safis avatar
UTC

Ossessionato
1979 P150X, 1983 P200E, 1987 PK125XL Elestart, 1988 T5, 1995 PX200E, 2011 Yamaha Fazer 600 S2
Joined: UTC
Posts: 4158
Location: Veria, Greece
 
Ossessionato
@safis avatar
1979 P150X, 1983 P200E, 1987 PK125XL Elestart, 1988 T5, 1995 PX200E, 2011 Yamaha Fazer 600 S2
Joined: UTC
Posts: 4158
Location: Veria, Greece
UTC quote
Ah, OK. Didn't see it's a 300. Yeah, if you get oil on the outside, defo needs replacing. And yes, pump can be changed from the oil pan sideā€¦
OP
@baboon99 avatar
UTC

Enthusiast
Piaggio MP3 300ie
Joined: UTC
Posts: 54
Location: South Shields
 
Enthusiast
@baboon99 avatar
Piaggio MP3 300ie
Joined: UTC
Posts: 54
Location: South Shields
UTC quote
Just an update found the oils was coming out of the oils pressure sensor next to the spade connector.
Replace sensor no leaks now and no oil light coming on
DoubleGood Design banner

Modern Vespa is the premier site for modern Vespa and Piaggio scooters. Vespa GTS300, GTS250, GTV, GT200, LX150, LXS, ET4, ET2, MP3, Fuoco, Elettrica and more.

Buy Me A Coffee
 

Shop on Amazon with Modern Vespa

Modern Vespa is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com


All Content Copyright 2005-2024 by Modern Vespa.
All Rights Reserved.


[ Time: 0.0217s ][ Queries: 4 (0.0033s) ][ Debug on ][ 313 ][ Thing One ]