OP
UTC

Lurker
2019 Primavera 150
Joined: UTC
Posts: 1
Location: NC
 
Lurker
2019 Primavera 150
Joined: UTC
Posts: 1
Location: NC
UTC quote
2019 Primavera 150. Hey everyone, I bought a pair of Primavera brand new 2019 150's around April of 2020. I rode one of them primarily and racked up 4500 miles on it and needed to change the tire. I dd this work myself and I had to remove the muffler to remove the tire. I got the new tire back on and reinstalled the muffler and now the check engine light comes on within a out 30 minutes of riding... also, I get a little sputtering and even a stall out now and then.

I decided to change the spark plug hoping that was the problem. The spark plug was black and burnt looking so I felt like I discovered (and fixed) the problem. Unfortunately I did not. The light still comes on and I still get a little sputtering from the engine..

Is it possible the O2 sensor is bad? Would that make the spark plug get black and cause some sputtering??

I had to unplug the sensor when changing the tire so this is my best guess.

Thanks in Advance fir any help!
@steelbytes avatar
UTC

Ossessionato
2019 GTS300 Supertech E3 55,000km
Joined: UTC
Posts: 4925
Location: Batmania aka Melbourne, Australia
 
Ossessionato
@steelbytes avatar
2019 GTS300 Supertech E3 55,000km
Joined: UTC
Posts: 4925
Location: Batmania aka Melbourne, Australia
UTC quote
Possibly the exhaust bushing is damaged
DoubleGood Design banner

Modern Vespa is the premier site for modern Vespa and Piaggio scooters. Vespa GTS300, GTS250, GTV, GT200, LX150, LXS, ET4, ET2, MP3, Fuoco, Elettrica and more.

Buy Me A Coffee
 

Shop on Amazon with Modern Vespa

Modern Vespa is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com


All Content Copyright 2005-2024 by Modern Vespa.
All Rights Reserved.


[ Time: 0.0269s ][ Queries: 3 (0.0015s) ][ Debug on ][ 309 ][ Thing One ]