OP
@crh avatar
UTC

Member
Piaggio MP3 400ie
Joined: UTC
Posts: 12
Location: Adelaide
 
Member
@crh avatar
Piaggio MP3 400ie
Joined: UTC
Posts: 12
Location: Adelaide
UTC quote
Hi everyone,

I have encountered a weird problem on my 2008 Piaggio MP 3 400. Bike has been performing brilliantly for many years until about 3 months ago.

When I release the parking brake, the parking brake light extinguishes but the red tilt lock warning light starts flashing and the yellow tilt lock light doesn't come on at all.

I turn the bike off. Wait several seconds and turn it back on. Problem remains. Red warning light for tilt lock system flashes (no beeps) and the yellow tilt lock light won't come on. So, I ride for around 5 minutes. Stop the engine. Wait several seconds and re-start and all is good. Red tilt lock warning light extinguished and the yellow tilt lock light flashing all back to normal. But if I apply and then release the handbrake, the problem I have described above returns. Only happens when I release the handbrake.

Bike is able to be ridden. No seat sensor issues. Reservoir is full. Wheel sensors are clean. No broken or cracked wiring.

Has anyone had this happen to them and if so, how did you fix it ?

Thanks in advance.
UTC

Enthusiast
2009 mp3
Joined: UTC
Posts: 82
Location: Brisbane
 
Enthusiast
2009 mp3
Joined: UTC
Posts: 82
Location: Brisbane
UTC quote
The microswitch on the cable brake of the tilt lock might be out of adjustment or the plug to the instrument display might not be making good contact. The microswitch I think tells the Ecu to stop flashing on the yellow light and turn it on solidly. Operating the parking brake probably provides enough vibration for the problem to occur. From the circuit it just switches the parking brake warning light on or off nothing to do with the tilt lock.
OP
@crh avatar
UTC

Member
Piaggio MP3 400ie
Joined: UTC
Posts: 12
Location: Adelaide
 
Member
@crh avatar
Piaggio MP3 400ie
Joined: UTC
Posts: 12
Location: Adelaide
UTC quote
I did consider that and in this instance, the red tilt lock light is eliminating the yellow tilt lock light completely when I release the park brake. I'm guessing there is going to be no way around it but to pull all the plastic off so I can see what's going on ..... thanks for your response.
DoubleGood Design banner

Modern Vespa is the premier site for modern Vespa and Piaggio scooters. Vespa GTS300, GTS250, GTV, GT200, LX150, LXS, ET4, ET2, MP3, Fuoco, Elettrica and more.

Buy Me A Coffee
 

Shop on Amazon with Modern Vespa

Modern Vespa is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com


All Content Copyright 2005-2024 by Modern Vespa.
All Rights Reserved.


[ Time: 0.0237s ][ Queries: 3 (0.0017s) ][ Debug on ][ 309 ][ Thing One ]