OP
UTC

Member
Joined: UTC
Posts: 5
 
Member
Joined: UTC
Posts: 5
UTC quote
Hi guys!

I have a Vespa GTS 300 Super 2017.

At first start it starts properly. Later i stop and try to go again but it wont start.

Sometimes its turns over but doesnt start. After a couple of tries maybe its starts but sometimes I still have to play with it. If I pull the throttle and let it go, it starts. But just when the throttle went back to the normal position not before.

When I stop at a light its starts to decrease the rpm and almost stops. Several times it does. Sometimes the ASR lamp comes on as well.


What should be the problem? Electrical or mechanical?

Thank you
@der_blechfahrer avatar
UTC

Molto Verboso
ET3 & PX150 & GTS 300 Super Sport MY23 & Yamaha Neo's electric
Joined: UTC
Posts: 1881
Location: Berlin
 
Molto Verboso
@der_blechfahrer avatar
ET3 & PX150 & GTS 300 Super Sport MY23 & Yamaha Neo's electric
Joined: UTC
Posts: 1881
Location: Berlin
UTC quote
Could be a faulty fuel pump. Try riding with a half tank and stop at a gas station when you think the problem will appear. If it does, see if filling up with cold gas can solve the problem. Alternatively, see whether waiting 30 minutes will make it go away.
@jimc avatar
UTC

Moderaptor
The Hornet (GT200, aka Love Bug) and 'Dimples' - a GTS 300
Joined: UTC
Posts: 43934
Location: Pleasant Hill, CA
 
Moderaptor
@jimc avatar
The Hornet (GT200, aka Love Bug) and 'Dimples' - a GTS 300
Joined: UTC
Posts: 43934
Location: Pleasant Hill, CA
UTC quote
Could be the air idle bypass in the throttle body is partially blocked. This means the mixture will be too rich at idle when the engine is fully warmed up, causing lower rpms and occasional stalling.

Opening the throttle and closing it again would allow some fresh air into the intake manifold, which would alleviate the 'too rich' scenario.

Solution - clean the air idle bypass:
https://cheekythoma3.wixsite.com/itsme/idle
@californiacruising avatar
UTC

Addicted
2015 Sprint 150, 2018 GTS 300
Joined: UTC
Posts: 894
Location: SoCal
 
Addicted
@californiacruising avatar
2015 Sprint 150, 2018 GTS 300
Joined: UTC
Posts: 894
Location: SoCal
UTC quote
Valve adjustment???
@steelbytes avatar
UTC

Veni, Vidi, Posti
2019 GTS300 Supertech E3 60,000km
Joined: UTC
Posts: 5730
Location: Batmania aka Melbourne, Australia
 
Veni, Vidi, Posti
@steelbytes avatar
2019 GTS300 Supertech E3 60,000km
Joined: UTC
Posts: 5730
Location: Batmania aka Melbourne, Australia
UTC quote
my first thought is the same as jimc
UTC

Hooked
'06 GTS 250; '18 GTS 300; '21 Liberty 150
Joined: UTC
Posts: 114
Location: Oregon
 
Hooked
'06 GTS 250; '18 GTS 300; '21 Liberty 150
Joined: UTC
Posts: 114
Location: Oregon
UTC quote
I had a very similar problem, '18GTS. Replacing the OEM starter fixed the issue. After trying the relay and battery, neither were the problem.

Bike would start cold every time. Once warm it would be random if it would crank over or give me nothing.
⬆️    About 2 months elapsed    ⬇️
OP
UTC

Member
Joined: UTC
Posts: 5
 
Member
Joined: UTC
Posts: 5
UTC quote
Update!

A new mechanic has determined that the ECU is faulty. During driving, there are instances when the RPM drops slightly, as if a stronger gust of wind is hitting, but it's not related to the weather. I'm about to purchase the new ECU, I'm ordering it from SIP. Does it come with a master key, or can the old one be programmed for the new ECU? Customer support is quite slow to respond to anything.

Thanks
UTC

Molto Verboso
Vespa GTS 300
Joined: UTC
Posts: 1081
Location: Germany
 
Molto Verboso
Vespa GTS 300
Joined: UTC
Posts: 1081
Location: Germany
UTC quote
imbensmith wrote:
Update!

A new mechanic has determined that the ECU is faulty. During driving, there are instances when the RPM drops slightly, as if a stronger gust of wind is hitting, but it's not related to the weather. I'm about to purchase the new ECU, I'm ordering it from SIP. Does it come with a master key, or can the old one be programmed for the new ECU? Customer support is quite slow to respond to anything.

Thanks
On new/virgin ECU first(!) Key used/programmed is automatically new Master: Make sure that the brown one (with foldable Chip) is used first. A foldable Chip makes programming secondary keys much more easy.

Immobiliser Codes:
Immobilizer LED codes

How to programm Keys:
ALL: Programming New Keys
OP
UTC

Member
Joined: UTC
Posts: 5
 
Member
Joined: UTC
Posts: 5
UTC quote
Thank you.
The seller didnt find the brown key. So I have the new ECU but dont have brown/red key. Do you know where can I order new ones with the lock as well?
Cheers
@jimc avatar
UTC

Moderaptor
The Hornet (GT200, aka Love Bug) and 'Dimples' - a GTS 300
Joined: UTC
Posts: 43934
Location: Pleasant Hill, CA
 
Moderaptor
@jimc avatar
The Hornet (GT200, aka Love Bug) and 'Dimples' - a GTS 300
Joined: UTC
Posts: 43934
Location: Pleasant Hill, CA
UTC quote
imbensmith wrote:
Thank you.
The seller didnt find the brown key. So I have the new ECU but dont have brown/red key. Do you know where can I order new ones with the lock as well?
Cheers
https://www.sip-scootershop.com/en/product/cylinder-locks-ignition-lock_MV577454
@preddybaer avatar
UTC

Hooked
GTS300, CRF1000 & Moto 6.5
Joined: UTC
Posts: 489
Location: Berlin, Germany
 
Hooked
@preddybaer avatar
GTS300, CRF1000 & Moto 6.5
Joined: UTC
Posts: 489
Location: Berlin, Germany
UTC quote
I had similar problems with my Froggy (after comming back from a regular maintenance, other story for other time).

After long root cause investigation and changing various parts, it came out to be the code antenna (example here at SIP https://www.sip-scootershop.com/en/product/antenna-piaggio-immobilizer_PI638534?q=code%20antenna). Once it was swapped, never had the same problems again.

Very expensive part for a piece of plastic with a connector and the copper coil (and a printed P/N sticker)!

If you manage to get from someone spare part to try it, do a check. It helped Froggy. By the way, Froggy way MY2017 GTS 300 in gorgeous metallic green.
@preddybaer avatar
UTC

Hooked
GTS300, CRF1000 & Moto 6.5
Joined: UTC
Posts: 489
Location: Berlin, Germany
 
Hooked
@preddybaer avatar
GTS300, CRF1000 & Moto 6.5
Joined: UTC
Posts: 489
Location: Berlin, Germany
UTC quote
imbensmith wrote:
Thank you.
The seller didnt find the brown key. So I have the new ECU but dont have brown/red key. Do you know where can I order new ones with the lock as well?
Cheers
you better find that brown key or it will become quite expensive. that is your MASTER key.

If the seller did not sold you Vespa with the red key, get back to him/her. That is your only chance. Otherwise you'll need to change a lot of components which are connected with the immobilisation system.
OP
UTC

Member
Joined: UTC
Posts: 5
 
Member
Joined: UTC
Posts: 5
UTC quote
jimc wrote:
https://www.sip-scootershop.com/en/product/cylinder-locks-ignition-lock_MV577454
Cheers man. Is that a master key? So It will behave like a brown/red key with the new ECU?
Because I already have the new ECU.
OP
UTC

Member
Joined: UTC
Posts: 5
 
Member
Joined: UTC
Posts: 5
UTC quote
PreddyBaer wrote:
I had similar problems with my Froggy (after comming back from a regular maintenance, other story for other time).

After long root cause investigation and changing various parts, it came out to be the code antenna (example here at SIP https://www.sip-scootershop.com/en/product/antenna-piaggio-immobilizer_PI638534?q=code%20antenna). Once it was swapped, never had the same problems again.

Very expensive part for a piece of plastic with a connector and the copper coil (and a printed P/N sticker)!

If you manage to get from someone spare part to try it, do a check. It helped Froggy. By the way, Froggy way MY2017 GTS 300 in gorgeous metallic green.
Did you change the ECU as well? Because I just have the new one. Maybe it will be solving my problem. But yeah, new master key neccessary cause the guy still didnt find the master key
@preddybaer avatar
UTC

Hooked
GTS300, CRF1000 & Moto 6.5
Joined: UTC
Posts: 489
Location: Berlin, Germany
 
Hooked
@preddybaer avatar
GTS300, CRF1000 & Moto 6.5
Joined: UTC
Posts: 489
Location: Berlin, Germany
UTC quote
imbensmith wrote:
Did you change the ECU as well? Because I just have the new one. Maybe it will be solving my problem. But yeah, new master key neccessary cause the guy still didnt find the master key
since I had my red master key, replacement of the ECU was not necessary, only the blo*dy antenna part I gave the link for.

in your case I presume that, with the missing master key, you do not have any other option than to change ECU as well. but only swap of the antenna will most likely sort out the problem described in the introduction of the thread.

sorry mate for bringing the bad news. my problems occurred in the guarantee period after being at regular maintenance. let's say that I did not managed to get it corrected under Guarantee and that the event spoiled my relationship with the Service I was liking to go to (in addition few other minor things which came along and confirmed that my decision was correct, at least in my case). I have now new Service I am more than happy about.
DoubleGood Design banner

Modern Vespa is the premier site for modern Vespa and Piaggio scooters. Vespa GTS300, GTS250, GTV, GT200, LX150, LXS, ET4, ET2, MP3, Fuoco, Elettrica and more.

Buy Me A Coffee
 

Shop on Amazon with Modern Vespa

Modern Vespa is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com


All Content Copyright 2005-2024 by Modern Vespa.
All Rights Reserved.


[ Time: 0.1109s ][ Queries: 5 (0.0997s) ][ live ][ 313 ][ ThingOne ]