OP
UTC

Lurker
Vespa GTS 2010 300cc
Joined: UTC
Posts: 3
Location: London
 
Lurker
Vespa GTS 2010 300cc
Joined: UTC
Posts: 3
Location: London
UTC quote
Hi guys, new member here!

I have a GTS 300 2010 model with 24,000 km on the clock.

I have recently purchased this bike a couple months back and over the last couple weeks it started causing me issues. The issue is that when riding at any speed it just started losing power and jerking or not responding to pulling the throttle.

I have taken this bike to two mechanics and they had fixed lots of minor issues, so far I've had the fuel injector changed, air-box tightened (it was loose), exhaust taken apart and tightened up as the intake manifold was loose (this is an aftermarket Remus and the mechanic said the end can is on its way out), I've had the bike serviced ( oil change, oil filter, air filter, iridium spark plug) and I also changed the entire transmission side of the bike to Polini, 6-speed variator, clutch, clutch bell, belt and rollers.

The exhaust tends to pop a lot, especially when it's about to cut out or lose power. Not sure if that has any relevance but I've given all the information possible.

Is there anyone who knows what this issue could be?
UTC

Molto Verboso
portofino green GTV 300
Joined: UTC
Posts: 1410
Location: w.ma. Northampton
 
Molto Verboso
portofino green GTV 300
Joined: UTC
Posts: 1410
Location: w.ma. Northampton
UTC quote
Has anybody checked the valve clearance, and welcome to MV.
@ks7877 avatar
UTC

Ossessionato
Joined: UTC
Posts: 2337
Location: So Cal
 
Ossessionato
@ks7877 avatar
Joined: UTC
Posts: 2337
Location: So Cal
UTC quote
Jaythetrackman wrote:
... the fuel injector changed, air-box tightened (it was loose), exhaust taken apart and tightened up as the intake manifold was loose (this is an aftermarket Remus and the mechanic said the end can is on its way out), I've had the bike serviced ( oil change, oil filter, air filter, iridium spark plug) and I also changed the entire transmission side of the bike to Polini, 6-speed variator, clutch, clutch bell, belt and rollers...
Hi Jaythetrackman and welcome to Modern Vespa.

I have experienced losing power / stalling when the engine is warmed up and at speed. There have been a number of causes: cracked fuel line, failing stator, loose spark plug cap and boot, voltage regulator, ECU and a faulty kill switch.

There are a couple of threads that have discussed similar issues. Maybe take a look here: Another stalling GTS

Hope you get it all sorted!
OP
UTC

Lurker
Vespa GTS 2010 300cc
Joined: UTC
Posts: 3
Location: London
 
Lurker
Vespa GTS 2010 300cc
Joined: UTC
Posts: 3
Location: London
UTC quote
Thank you guys for your replies! The valve clearances have been checked and said to be fine from one mechanic. I'll order a few new parts battery, voltage regulator, stator motor and hot coil lead and hopefully this works, it seems it could be so many issues and it will cost a fortune to fix. My mechanic is probably buying his next home off my little Vespa 😂
@steelbytes avatar
UTC

Veni, Vidi, Posti
2019 GTS300 Supertech E3 60,000km
Joined: UTC
Posts: 5710
Location: Batmania aka Melbourne, Australia
 
Veni, Vidi, Posti
@steelbytes avatar
2019 GTS300 Supertech E3 60,000km
Joined: UTC
Posts: 5710
Location: Batmania aka Melbourne, Australia
UTC quote
Jaythetrackman wrote:
The exhaust tends to pop a lot, especially when it's about to cut out or lose power. Not sure if that has any relevance but I've given all the information possible.
my understanding of popping is that it usually means a little unburnt fuel making into the exhaust. can happen if air restriction (you've had the filter replaced so I doubt that) or the spark is missing occasionally (sparkplug cap / lead / coil).

also do you have the catalytic installed in your exhaust? and do you have the original exhaust handy?
@scooter_curmudgeon avatar
UTC

Hooked
GT200/GTS300/Primavera 150
Joined: UTC
Posts: 107
Location: Olympia, WA (US)
 
Hooked
@scooter_curmudgeon avatar
GT200/GTS300/Primavera 150
Joined: UTC
Posts: 107
Location: Olympia, WA (US)
UTC quote
I've had a similar situation with both a GT200 (carbureted) and GTS250 (injected). The local Vespa mechanic determined that it was a spark plug on the GTS and, once replaced, everything seems to be working as it should. I'm going to replace the plug on the GT this week, and see if it resolves.

Shouldn't equate to any significant portion of a house payment, I expect.

Bob
OP
UTC

Lurker
Vespa GTS 2010 300cc
Joined: UTC
Posts: 3
Location: London
 
Lurker
Vespa GTS 2010 300cc
Joined: UTC
Posts: 3
Location: London
UTC quote
I don't have the original exhaust but I'm looking to buy one tomorrow. Apparently they're superior to anything aftermarket anyway, so I'd stick with the original once I get it. I do have a spare spark plug and I've ordered a replacement for the complete ht coil, brand new. New battery, voltage regulator and stator motor, all parts from SIP.

Could be a little OTT replacing so much but I really cannot afford for this bike to have any more issues because I use it for work.

I know it's no equivalent to a house but I genuinely have well overspent on this bike and the value is no where near my outgoings on it.

I'm not planning on selling it anytime soon, if ever at all because I genuinely love the bike. I'll let you guys know how it goes once all the parts are fitted.
@cballweg avatar
UTC

Hooked
Honda Aero 1100
Joined: UTC
Posts: 215
Location: Allen. TX
 
Hooked
@cballweg avatar
Honda Aero 1100
Joined: UTC
Posts: 215
Location: Allen. TX
UTC quote
Jaythetrackman wrote:
Hi guys, new member here!

I have a GTS 300 2010 model with 24,000 km on the clock.

I have recently purchased this bike a couple months back and over the last couple weeks it started causing me issues. The issue is that when riding at any speed it just started losing power and jerking or not responding to pulling the throttle.

I have taken this bike to two mechanics and they had fixed lots of minor issues, so far I've had the fuel injector changed, air-box tightened (it was loose), exhaust taken apart and tightened up as the intake manifold was loose (this is an aftermarket Remus and the mechanic said the end can is on its way out), I've had the bike serviced ( oil change, oil filter, air filter, iridium spark plug) and I also changed the entire transmission side of the bike to Polini, 6-speed variator, clutch, clutch bell, belt and rollers.

The exhaust tends to pop a lot, especially when it's about to cut out or lose power. Not sure if that has any relevance but I've given all the information possible.

Is there anyone who knows what this issue could be?
@jimc avatar
UTC

Moderaptor
The Hornet (GT200, aka Love Bug) and 'Dimples' - a GTS 300
Joined: UTC
Posts: 43894
Location: Pleasant Hill, CA
 
Moderaptor
@jimc avatar
The Hornet (GT200, aka Love Bug) and 'Dimples' - a GTS 300
Joined: UTC
Posts: 43894
Location: Pleasant Hill, CA
UTC quote
Have either or both the spark plug cap and the HT lead been replaced? The cap in particular is the first thing to check when there's an intermittent loss of power.
@mr_fix_it avatar
UTC

Member
2021 GTS 300 Super, 1980 Vespa 100 Sport, 2009 Stella 2T
Joined: UTC
Posts: 29
Location: York, Pennsylvania
 
Member
@mr_fix_it avatar
2021 GTS 300 Super, 1980 Vespa 100 Sport, 2009 Stella 2T
Joined: UTC
Posts: 29
Location: York, Pennsylvania
UTC quote
Check the harness that runs along the right side of the engine. My friend had a similar issue. It usually wasn't enough to pop the fuse, but it was the wire for power to the Engine Control Unit (ECU). It would go to ground because it was rubbing against the frame. The routing of the harness in the 2010 prodution time period was prone to rubbing against the frame.
@mr_fix_it avatar
UTC

Member
2021 GTS 300 Super, 1980 Vespa 100 Sport, 2009 Stella 2T
Joined: UTC
Posts: 29
Location: York, Pennsylvania
 
Member
@mr_fix_it avatar
2021 GTS 300 Super, 1980 Vespa 100 Sport, 2009 Stella 2T
Joined: UTC
Posts: 29
Location: York, Pennsylvania
UTC quote
Harness rubbed through
Forum member supplied image with no explanatory text
@srd0060 avatar
UTC

Hooked
2022 HPE 300 tech/ 91 PX 200e/97 PX 200e
Joined: UTC
Posts: 109
Location: Australia
 
Hooked
@srd0060 avatar
2022 HPE 300 tech/ 91 PX 200e/97 PX 200e
Joined: UTC
Posts: 109
Location: Australia
UTC quote
Mr. Fix It wrote:
Harness rubbed through
This is a very common fault.
DoubleGood Design banner

Modern Vespa is the premier site for modern Vespa and Piaggio scooters. Vespa GTS300, GTS250, GTV, GT200, LX150, LXS, ET4, ET2, MP3, Fuoco, Elettrica and more.

Buy Me A Coffee
 

Shop on Amazon with Modern Vespa

Modern Vespa is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com


All Content Copyright 2005-2024 by Modern Vespa.
All Rights Reserved.


[ Time: 0.0130s ][ Queries: 4 (0.0073s) ][ live ][ 313 ][ ThingOne ]