OP
@xtine avatar
UTC

Hooked
Vespa GTS250, PX125
Joined: UTC
Posts: 306
Location: Los Angeles, CA
 
Hooked
@xtine avatar
Vespa GTS250, PX125
Joined: UTC
Posts: 306
Location: Los Angeles, CA
UTC quote
I recently changed my battery on my Vespa GTS and recently started facing some issues. Namely the LED flickers a lot, almost strobe like. Then when I ride for a while my engine might cut off and it's difficult to start up again, but if I really try to throttle while starting it'll catch and I can ride again for a while.

Could this be a bad/weak battery or other problems? Considering both the LED flickering and engine sometimes shutting off and difficulty starting all after a change but I wont rule out coincidence if there are other things I need to address at the same time. Help appreciated!
@marret avatar
UTC

Hooked
2016 GTS300 ABS
Joined: UTC
Posts: 228
Location: FL and VA
 
Hooked
@marret avatar
2016 GTS300 ABS
Joined: UTC
Posts: 228
Location: FL and VA
UTC quote
Definitely need to check voltage on the battery at rest and when the scooter is running to start.

Edit to add, agree with znomit below, good idea to check that the connections are tight.
⚠️ Last edited by marret on UTC; edited 2 times
@znomit avatar
UTC

Veni, Vidi, Posti
LX190 Friday afternoon special, Primavera, some pushbikes
Joined: UTC
Posts: 9861
Location: Hermit Kingdom
 
Veni, Vidi, Posti
@znomit avatar
LX190 Friday afternoon special, Primavera, some pushbikes
Joined: UTC
Posts: 9861
Location: Hermit Kingdom
UTC quote
Check the battery connections are tight.
@steelbytes avatar
UTC

Ossessionato
2019 GTS300 Supertech E3 55,000km
Joined: UTC
Posts: 4862
Location: Batmania aka Melbourne, Australia
 
Ossessionato
@steelbytes avatar
2019 GTS300 Supertech E3 55,000km
Joined: UTC
Posts: 4862
Location: Batmania aka Melbourne, Australia
UTC quote
and if it ain't the battery then maybe it's the regulator
@buggsy avatar
UTC

Hooked
GTV / GTS
Joined: UTC
Posts: 344
Location: Somewhere on the Island of Great Britain, East Coast, Last time I looked.
 
Hooked
@buggsy avatar
GTV / GTS
Joined: UTC
Posts: 344
Location: Somewhere on the Island of Great Britain, East Coast, Last time I looked.
UTC quote
You say, you changed the battery, was it for a new one ?, if it was, and gel type did you charge it to capacity before use, also check voltage regulator.
OP
@xtine avatar
UTC

Hooked
Vespa GTS250, PX125
Joined: UTC
Posts: 306
Location: Los Angeles, CA
 
Hooked
@xtine avatar
Vespa GTS250, PX125
Joined: UTC
Posts: 306
Location: Los Angeles, CA
UTC quote
znomit wrote:
Check the battery connections are tight.
Well you know what, I opened the battery cover, and the connection was super loose. Facepalm emoticon
Tightened it and of course, the LED headlight stopped flickering. Strong and bright, hopefully this is also the cause of engine cutoff issues!! Will ride some more and see if it happens again.

So glad it was the easy fix.
DoubleGood Design banner

Modern Vespa is the premier site for modern Vespa and Piaggio scooters. Vespa GTS300, GTS250, GTV, GT200, LX150, LXS, ET4, ET2, MP3, Fuoco, Elettrica and more.

Buy Me A Coffee
 

Shop on Amazon with Modern Vespa

Modern Vespa is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com


All Content Copyright 2005-2024 by Modern Vespa.
All Rights Reserved.


[ Time: 0.0297s ][ Queries: 4 (0.0047s) ][ Debug on ][ 309 ][ Thing One ]