OP
UTC

Lurker
Vespa 300 GTS HPE, Vespa 300 GTS
Joined: UTC
Posts: 2
Location: Switzerland
 
Lurker
Vespa 300 GTS HPE, Vespa 300 GTS
Joined: UTC
Posts: 2
Location: Switzerland
UTC quote
Hello everyone, I'm quite a mechanic and have everything I need to work on my vespa. I've searched the forum but haven't found anything on the subject. I bought a vespa 300 gts 2013 without keys and a lot of rust, changed the lock and coded the engine control unit to the new keys and welded the rust holes with tig. I adjusted the valve clearance and checked the timing.
Everything looked good and it starts immediately and runs well at idle. But when I accelerate it dies immediately. The fuel pump works and has pressure on it, the nozzle does not spray cleanly, I cleaned with ultrashall, but unfortunately the situation has not changed, I also changed the spark plug without success. With the Digitek diagnostic device I can see that from 4 degrees throttle / 1800 rpm the engine stalls. Every Parameter looks good and no engine light and no dtc is stored. I think the air/petrol mixture is not right, there is no false air, I checked it by spraying brake cleaner on the hoses when the engine was cold. Does someone know more?
@steelbytes avatar
UTC

Veni, Vidi, Posti
2019 GTS300 Supertech E3 60,000km
Joined: UTC
Posts: 5730
Location: Batmania aka Melbourne, Australia
 
Veni, Vidi, Posti
@steelbytes avatar
2019 GTS300 Supertech E3 60,000km
Joined: UTC
Posts: 5730
Location: Batmania aka Melbourne, Australia
UTC quote
are you sure coded the keys correctly? iirc when the ecu has no keys coded (eg reset or brand new) then it can't run above idle.
@jimc avatar
UTC

Moderaptor
The Hornet (GT200, aka Love Bug) and 'Dimples' - a GTS 300
Joined: UTC
Posts: 43934
Location: Pleasant Hill, CA
 
Moderaptor
@jimc avatar
The Hornet (GT200, aka Love Bug) and 'Dimples' - a GTS 300
Joined: UTC
Posts: 43934
Location: Pleasant Hill, CA
UTC quote
SteelBytes wrote:
are you sure coded the keys correctly? iirc when the ecu has no keys coded (eg reset or brand new) then it can't run above idle.
It would just get rev-limited to 2000, it wouldn't stall out.
@steelbytes avatar
UTC

Veni, Vidi, Posti
2019 GTS300 Supertech E3 60,000km
Joined: UTC
Posts: 5730
Location: Batmania aka Melbourne, Australia
 
Veni, Vidi, Posti
@steelbytes avatar
2019 GTS300 Supertech E3 60,000km
Joined: UTC
Posts: 5730
Location: Batmania aka Melbourne, Australia
UTC quote
jimc wrote:
It would just get rev-limited to 2000, it wouldn't stall out.
that's what I though, but interesting coincidence that they had reprogrammed the keys (and I cna't think of another reason)
@steelbytes avatar
UTC

Veni, Vidi, Posti
2019 GTS300 Supertech E3 60,000km
Joined: UTC
Posts: 5730
Location: Batmania aka Melbourne, Australia
 
Veni, Vidi, Posti
@steelbytes avatar
2019 GTS300 Supertech E3 60,000km
Joined: UTC
Posts: 5730
Location: Batmania aka Melbourne, Australia
UTC quote
SteelBytes wrote:
I cna't think of another reason
pondering more ...

exhaust blocked?

is it instant cut as though by the ecu or is it that it struggles and dies?
@jimc avatar
UTC

Moderaptor
The Hornet (GT200, aka Love Bug) and 'Dimples' - a GTS 300
Joined: UTC
Posts: 43934
Location: Pleasant Hill, CA
 
Moderaptor
@jimc avatar
The Hornet (GT200, aka Love Bug) and 'Dimples' - a GTS 300
Joined: UTC
Posts: 43934
Location: Pleasant Hill, CA
UTC quote
SteelBytes wrote:
pondering more ...

exhaust blocked?
Good thought - and we've had a couple of cat 'extrusions' reported recently. Could easily happen, especially to a rusty neglected bike!

What about a clogged air filter? Enough air might get past for idle, but when throttle is demanded, the extra squirt of fuel given for acceleration might get the engine to stumble and die (but that's just speculation).
@jimc avatar
UTC

Moderaptor
The Hornet (GT200, aka Love Bug) and 'Dimples' - a GTS 300
Joined: UTC
Posts: 43934
Location: Pleasant Hill, CA
 
Moderaptor
@jimc avatar
The Hornet (GT200, aka Love Bug) and 'Dimples' - a GTS 300
Joined: UTC
Posts: 43934
Location: Pleasant Hill, CA
UTC quote
Oh - and is "ultrashall" an ultrasonic cleaner?
OP
UTC

Lurker
Vespa 300 GTS HPE, Vespa 300 GTS
Joined: UTC
Posts: 2
Location: Switzerland
 
Lurker
Vespa 300 GTS HPE, Vespa 300 GTS
Joined: UTC
Posts: 2
Location: Switzerland
UTC quote
Good evening,
Thanks for the hint, I had reset the engine control unit and deleted the keys, but did not create new keys, is really strange the behavior of the immobilizer, would have preferred that it does not start and stores an error code in the memory, have I overlooked something or is this mentioned in the workshop manual?
Or do you just need to know that?

With the Digitek diagnostic device I can only read the immobilizer and query the status but not learn the keys, I had to use the AWS Next in combination with the Xhorse Key Programmer to read the ID.

Thanks again! Saved me a lot of headaches and time! Facepalm emoticon

Yes it's ultrasonic and not ultrashall, ultrashall is in german 😅
DoubleGood Design banner

Modern Vespa is the premier site for modern Vespa and Piaggio scooters. Vespa GTS300, GTS250, GTV, GT200, LX150, LXS, ET4, ET2, MP3, Fuoco, Elettrica and more.

Buy Me A Coffee
 

Shop on Amazon with Modern Vespa

Modern Vespa is a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for sites to earn advertising fees by advertising and linking to amazon.com


All Content Copyright 2005-2024 by Modern Vespa.
All Rights Reserved.


[ Time: 0.0073s ][ Queries: 3 (0.0017s) ][ live ][ 313 ][ ThingOne ]